If You Need Assistance

Support for the MSP430 device and the eZ430-F2013 is
provided by the Texas Instruments Product Information Center
(PIC). Contact information for the PIC can be found on the Tl
web site at www.ti.com. Additional device-specific information
can be found on the MSP430 web site at www.ti.com/msp430
and www.ti.com/ez430.

Note: Kickstart is supported by Texas Instruments

Although Kickstart is a product of IAR, Texas Instruments provides the
support for it. Therefore, please do not request support for Kickstart from
IAR. Please consult the extensive documentation provided with Kickstart
before requesting assistance.

FCC Warning

This equipment is intended for use in a laboratory test
environment only. It generates, uses, and can radiate radio
frequency energy and has not been tested for compliance with
the limits of computing devices pursuant to subpart J of part 15
of FCC rules, which are designed to provide reasonable
protection against radio frequency interference. Operation of
this equipment in other environments may cause interference
with radio communications, in which case the user at his own
expense will be required to take whatever measures may be
required to correct this interference.



1. Kit Contents, eZ430-F2013

e One eZ430-F2013. The hardware is housed inside a plastic
enclosure that may be opened in order to separate the MSP-EZ430D
target board from the MSP-EZ430U debugging interface.

e One MSP430 Development Tool CD-ROM which contains several
documents including the following related to the eZ430-F2013:

o  MSP430x2xx Family User’'s Guide, SLAU144B
¢ MSP-FET430 FLASH Emulation Tool User’s Guide, SLAU138C

e MSP-FET430 FLASH Emulation Tool User's Guide Errata,
SLAZ027

e eZ430-F2013 User’s Guide (this document)
¢ |AR Embedded Workbench (Kickstart Version)

2. eZ430-F2013 Overview

The eZ430-F2013 is a complete MSP430 development tool providing all
the hardware and software to evaluate the MSP430F2013 and complete
an entire project in a convenient USB stick form factor. The eZ430-
F2013 uses the IAR Embedded Workbench Integrated Development
Environment (IDE) to provide full emulation with the option of designing a
stand-alone system or detaching the removable target board to integrate
into an existing design. The USB port provides power to operate the
ultra-low-power MSP430 so no external power supply is required.

All 14-pins on the MSP430F2013 are accessible on the MSP-EZ430D
target board for easy debugging and interfacing with peripherals.
Additionally, one of the digital 1/0O pins is connected to an LED for visual
feedback. The MSP430F2013 includes 16-MIPS performance, a 16-bit
Sigma Delta Analog-to-Digital converter, a 16-bit timer, Watchdog timer,
brownout detector, a USI module supporting SPI and 1°C, and five low
power modes drawing as little as 0.5 pA standby.

Spy Bi-Wire Fully accessible
Interface MSP430 pins LED

MSP430F2013

Detachable MSP-EZ430D

MSP-EZ430U Debugging Interface Target Board

Figure 1. eZ430-F2013 Development Tool



3. Software Installation

1.

Insert the MSP430 CD-ROM into your computer. It should start
automatically, and the MSP430 start page will then be displayed.
You can also use a browser to open “index.htm” that is located in the
root directory of the MSP430 CD-ROM.

The eZ430-F2013 is compatible with Windows 2000 and XP.

Select Software > IAR Workbench Kickstart and follow the
instructions.

Respond to the prompts to install the software. The installation
procedure will install IAR and Tl files. Finish the installation.

Read the file C:\Program Files\IAR Systems\Embedded Workbench
4.0\430\doc\readme.htm from IAR for the latest information about the
Workbench. The term Kickstart is used to refer to the function-limited
version of Embedded Workbench including the C-SPY debugger.
Kickstart is supplied on the CD-ROM included with each MSP430 tool.
The latest version is available from the MSP430 web site at
www.ti.com/msp430.

The above documents are accessible using: Start > Programs > IAR
Systems > IAR Embedded Workbench Kickstart for MSP430 V3

4. Hardware Installation

Connect the eZ430-F2013 to a USB port of your PC.

If the Hardware Wizard starts, respond to the prompts and point the
wizard to the drivers located in the following directory on a default
installation:

C:\Program Files\IAR Systems\Embedded Workbench
4.0\430\drivers\TIUSBFET\WinXP

Two devices will be detected; however, the same directory is used
for both devices. Section 11 of the eZ430-F2013 User’s Guide gives
detailed instructions on how to install the USB drivers under
Windows 2000 and XP.



5. Flashing the LED Demo

This section demonstrates how to setup a project for the eZ430-F2013
and download the application to the MSP430F2013. The sample
program will blink the LED on the MSP-EZ430D target board.

Start the Workbench (Start > Programs - IAR Systems - IAR
Embedded Workbench Kickstart for MSP430 V3 > IAR Embedded
Workbench).

1.

9.

Use File > Open Workspace to open the file at C:\Program
Files\IAR Systems\Embedded Workbench 4.0\430\
FET_examples\Flashing the LED.eww. The workspace window will
open.

Click the msp430x2xx (C — SpyBiWire) tab at the bottom of the
workspace window that corresponds to the eZ430-F2013.

Set the correct device by clicking on Projects > Options >
General Options > Target and select the MSP430F2013 from the
device list.

In the Options windows, go to FET Debugger -> Setup >
Connection - TI USB FET to use the USB Interface.

Use Project = Rebuild All to build and link the source code. You
can view the source code by double-clicking on the project, and then
double-clicking on the displayed source file.

Use Project > Debug to start the C-SPY debugger. C-SPY wiill
erase the device Flash, and then download the application object file
to the device Flash.

Use Debug - Go to start the application. The LED should flash!

Use Debug > Stop Debugging to stop debugging, to exit C-SPY
and to return to the Workbench.

Use File > Exit to exit the Workbench.

Congratulations, you've just built and tested your first MSP430
application.



6. Using the MSP430F2013 Target Board & Debugging Interface

Independently

The eZ430-F2013 may be used as a stand-alone development board.
Additionally, the MSP-EZ430D target board may also be detached from
the debugging interface and integrated into another design.

The plastic enclosure can be removed to expose the MSP-EZ430U
debugging interface and the MSP-EZ430D target board. The MSP-
EZ430D target board is disconnected from the debugging interface by
gently pulling the two boards apart.

The target board can be used in a stand-alone design by interfacing to
the 14-pins of the MSP430F2013. Holes in the MSP-EZ430D target
board provide direct access to each pin of the MSP430F2013. Please
refer to the MSP430F2013 Data Sheet for descriptions of each pin’s
function.

The MSP-EZ430U debugging interface may also be used as a standard
Flash Emulation Tool for all devices in the MSP430F20xx family of
microcontrollers. Target boards using other supported MSP430F20xx
devices may be designed and flashed using the MSP-EZ430U
debugging interface.

7. Where To Go For More Information

The primary sources of MSP430 information are the device-specific data
sheets and User’s Guides. The most up to date versions of the User’'s
Guide documents available at the time of production have been provided
on the CD-ROM included with this tool. The most current information is
found at www.ti.com/msp430. Information specific to the e2430-F2013
development tool can be found at www.ti.com/ez430.

MSP430 device User’s Guides and the FET User's Guide may be
accessed from the main page on the CD-ROM under the User’s Guides
section. The FET User’s Guide includes detailed information on setting
up a project for the MSP430 using IAR.

Documents describing the IAR tools (Workbench/C-SPY, the assembler,
the C compiler, the linker, and the librarian) are located in common\doc
and 430\doc. The documents are in PDF-format. Supplements to the
documents (i.e., the latest information) are available in HTML-format
within the same directories. 430\doc\readme_start.htm provides a
convenient starting point for navigating the IAR documentation.



8. Frequently Asked Questions

1)

2)

3)

4)

o)

6)

7)

What devices can be programmed with the MSP-EZ430U
debugging interface?

The MSP-EZ430U debugging interface was designed to
communicate with devices over a Spy Bi-Wire interface. All
members of the MSP430F20xx family of microcontrollers have been
tested and are supported.

Does the eZ430-F2013 support fuse blow?

The MSP-EZ430U debugging interface lacks the JTAG security fuse
blow capability. To ensure firmware security on devices going to
production, the USB Flash Emulation Tool or the Gang Programmer,
which include the fuse blow feature are recommended.

What is the voltage supplied to the MSP-EZ430D target board
from the debugging interface?

The MSP-EZ430U debugging interface supplies a regulated 3.6V to
the MSP-EZ430D target board.

Can other programming tools interface to the MSP-EZ430D
target board?

The MSP-EZ430D target board will work with any programming tool
supporting the 2-wire Spy Bi-Wire interface. Both the MSP430 USB
FET and the Gang Programmer support these devices.

What versions of IAR Embedded Workbench are supported?
The eZ430-F2013 is supported by IAR Embedded Workbench 3.40A
and IAR Embedded Workbench (Kickstart Version) FET_R449 or
higher.

What are the part numbers for the connectors between the MSP-
EZ430U emulator and the MSP-EZ430D target board?

e Header: Mill-Max 850-10-004-20-001000
e Socket: Mill-Max 851-93-004-20-001000

Mill-Max: http://www.mill-max.com

Why does can’t the debugger get started (IAR Error: Failed to
initialize device)?

First, check in the Device Manager that the COM Port assigned to
the eZ430 does not conflict with port already in use. You may
disable the conflicting port or assign a new COM port to the device.
Check all devices that use a serial port; even devices that do not
show up in the Device Manager.

Second, check if capacitors C6 or C9 are missing on the MSP-
EZ430U debugging interface are populated. These capacitors may
have been unknowingly removed while opening the enclosure.



9. eZ430-F2013, Schematic
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Figure 2. MSP-EZ430U, Schematic



/2 Swmr_m_ dyGiTRIZO 90082/20/€ 91eQ
L
N3 $49QWNN YUswN>Do(
NOEL23-dSH +371LIL
£l0cd-0cvze
ano
= L e [~
@ @ 9] @
ane m m m m MdOVZSINS
> w O o FD
xee
aND  dNO
QNNH HQNN
oLo = -—Cl0
SNEA —
a ¥EE ce
+a —
dee ey
aNo ano
¥0 ole
. - ano ano
MOAl0ELLSdL
— 81 N3 g
ASOML 219
= s3y ano |+ ugoL
€0 = 9
H Tl ZINoO NI |m_ |_|
¢ LLNO NI !
Q0N pge+=00n °© g Snan

€n

ane
o0k _NB r
1N9104¥TLVYD
55n 5| 20A ssA | DON
—-q om @ |
s s 13 =
g AN ol : oL
zn L1 oLy
vas
10Ss
ane
] ane
H o uooL
-0
80
4 ot | [oy
dA0LPEESNL
%1001
o0zy % wmuw W 4 ole
8l Iz — OLPEATO
s ane 2]
- sraan ved b= oLy
%LMO0L 4 w%> MMM o Sy
o1 vm L1s3aL 0'ed %
5K e olsaL 08 7
=q wula vas |r
= sw A vy
5 <oy 1n0s ¢ e - axg
srq dod NS =71 axLt
g ¥sd SyILPNL
+=q s 1NOX10 == ans
1«a ld
aN3dsns [ =
—{ wa dnBdivm D=+ >m-©h3 I_I
5 <o 13538 g 1
r_H.|m uNnd NIOIUA [OT—
[STCIES = REAY

AGL
[45:]

H_v_of

[ 11y

Q0N

Figure 3. MSP-EZ430U, Schematic
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Figure 4. MSP-EZ430D / eZ430-T2012, Schematic




10. eZ430-F2013, PCB Pictorial

PCB dimension: 35x20mm PCB dimension: 15x20mm
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Figure 5. eZ430-2013, PCB Pictorial



11.Detailed Hardware Installation Guide
1. Install IAR Embedded Workbench (Kickstart Version) included on the CD.
2. Insert the eZ430-F2013 into a USB port of your PC.

3. Windows should recognize the new hardware as MSP-FET430UIF JTAG Tool
(Figure 6)

i) Found New Hardware E
MSP-FET430UIF ITAG Tool

£
|« MO M B, ) MO 3:30PM

Figure 6. Windows XP Hardware Recognition
4. The “Found New Hardware Wizard” should pop up with a dialog window.

5. Select “Install from a list or specific location [Advanced]’ (Figure 7).

Found New Hardware Wizard

Welcome to the Found New

I:I‘?‘ Hardware Wizard

Thig wizard helps you install software for:
MSP-FET430UIF (TI USE FET) Adapter

Z:'J i your hardware came with an installation CD
g orfloppy disk. insert it now.

‘What do you want the wizard to do?

™ Install the software automatically (Recommended)
% iinstal from a list or specific location (Advanced)

Click Mext to cortinue.

< Back et = Cancel

Figure 7. Hardware Wizard
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6. Point the Hardware Wizard to the folder containing the MSP-FET430UIF/eZ430-

F2013 driver. If you have already installed the IAR Kickstart Edition, the driver will

be found at the following default location: C:\Program Files\IAR
Systems\Embedded Workbench 4.0\1430\drivers\TIUSBFET\WinXP

Found New Hardware Wizard

Please choose your search and installation options. .

{* Search forthe best driver in these locations.

|Jse the check boxes below to limit or expand the default search, which includes local
paths and removable media. The best driver found will be installed.

™ Search removable media floppy, CO-ROM..)
¥ Include this location in the search;

Iu:leu:l Workbench 4004300 drivers\TIUSBFET \WinXP j Browse |

" Dont search. | will choose the driver to install.

Choose this option to select the device driver from a list. Windows does not guarantes that
the driver you choose will be the best match for your hardware.

< Back Menad > Cancel

Figure 8. Specify driver location

7. The Wizard should find the appropriate driver and on Windows XP system, it will
prompt you with a warning that Microsoft did not certify the driver. The drivers
have been tested exhaustively and you may ignore this warning and click
“Continue Anyway” (Figure 9).

Hardware Installation

' "_l., The software you are installing for this hardware:
L
MSP-FET430UIF (Tl USE FET) Adapter

has not passed Windows Logo testing to verfy its compatibility
with Windows XP. (Tell me why this testing is important.)

Continuing your installation of this software may impair
or destabilize the comect operation of your system
either immediately or in the future. Microsoft strongly
recommends that you stop this installation now and
contact the hardware vendor for software that has
passed Windows Logo testing.

STOP Installation

Figure 9. Windows XP Warning

11
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10.
11.

The Wizard will continue to install the driver and notify you that it has finished the

installation of the software.

After closing the Hardware Wizard, Windows will automatically recognize another
new hardware device called the “MSP-FET430UIF — Serial Port”

Repeat steps 4 — 8 for the second hardware detection.

The eZ430-F2013 is now installed and ready to use. The Device Manager should

list a new entry as shown in Figure 10.

L, Device Manager

File Action Wiew Help

=10l x|

= B FS 2 a=na

=&} LTAD869571

[]--H Batteries

[#]- :J Computer

[+]-%e# Disk drives

- Eé Display adapters

[z DVD/CD-ROM drives
[+-{idg Human Interface Devices
[+-{=% IDE ATA/ATAPI controllers
[ Keyboards

[-1) Mice and other pointing devices
[]---L Modems

- Mpoite

AL Multi-port serial adapters

- Ports (COM &LPT)

(%% Processors

g 5C5I and RAID controllers
Smart card readers

..

% System devices

[+ Universal Serial Bus controllers

MSP-FET430UIF (TI USB FET) Adapter

‘D Sound, video and game controllers

Figure 10. Device Manager
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