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Product Overview

The Arduino Uno is a microcontroller board based on the ATmega328 (datasheet). It has 14 digital
input/output pins (of which 6 can be used as PWM outputs), 6 analog inputs, a 16 MHz crystal oscillator, a
USB connection, a power jack, an ICSP header, and a reset button. It contains everything needed to
support the microcontroller; simply connect it to a computer with a USB cable or power it with a AC-to-DC
adapter or battery to get started. The Uno differs from all preceding boards in that it does not use the FTDI
USB-to-serial driver chip. Instead, it features the Atmega8U2 programmed as a USB-to-serial converter.

"Uno" means one in Italian and is named to mark the upcoming release of Arduino 1.0. The Uno and version
1.0 will be the reference versions of Arduno, moving forward. The Uno is the latest in a series of USB
Arduino boards, and the reference model for the Arduino platform; for a comparison with previous versions,
see the index of Arduino boards.
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Technical Specification

EAGLE files: arduino-duemilanove-uno-design.zip Schematic: arduino-uno-schematic.pdf

Summar

Microcontroller ATmega328

Operating Voltage 5V

Input Voltage (recommended) 7-12V

Input Voltage (limits) 6-20V

Digital 1/0 Pins 14 (of which 6 provide PWM output)

Analog Input Pins 6

DC Current per 1/0O Pin 40 mA

DC Current for 3.3V Pin 50 mA

Flash Memory 32 KB of which 0.5 KB used by
ootloader

SRAM 2 KB

EEPROM 1 KB

Clock Speed 16 MHz
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The Arduino Uno can be powered via the USB connection or with an external power supply. The power
source is selected automatically.

External (non-USB) power can come either from an AC-to-DC adapter (wall-wart) or battery. The adapter
can be connected by plugging a 2.1mm center-positive plug into the board's power jack. Leads from a
battery can be inserted in the Gnd and Vin pin headers of the POWER connector.

The board can operate on an external supply of 6 to 20 volts. If supplied with less than 7V, however, the 5V
pin may supply less than five volts and the board may be unstable. If using more than 12V, the voltage
regulator may overheat and damage the board. The recommended range is 7 to 12 volts.

The power pins are as follows:

« VIN. The input voltage to the Arduino board when it's using an external power source (as opposed to
5 volts from the USB connection or other regulated power source). You can supply voltage through
this pin, or, if supplying voltage via the power jack, access it through this pin.

e 5V. The regulated power supply used to power the microcontroller and other components on the
board. This can come either from VIN via an on-board regulator, or be supplied by USB or another
regulated 5V supply.

e 3V3. A 3.3 volt supply generated by the on-board regulator. Maximum current draw is 50 mA.

¢ GND. Ground pins.

The Atmega328 has 32 KB of flash memory for storing code (of which 0,5 KB is used for the bootloader); It
has also 2 KB of SRAM and 1 KB of EEPROM (which can be read and written with the EEPROM library).

Input and Output

Each of the 14 digital pins on the Uno can be used as an input or output, using pinMode(), digitalWrite(), and
digitalRead() functions. They operate at 5 volts. Each pin can provide or receive a maximum of 40 mA and
has an internal pull-up resistor (disconnected by default) of 20-50 kOhms. In addition, some pins have
specialized functions:

e Serial: 0 (RX) and 1 (TX). Used to receive (RX) and transmit (TX) TTL serial data. TThese pins are
connected to the corresponding pins of the ATmega8U2 USB-to-TTL Serial chip .

« External Interrupts: 2 and 3. These pins can be configured to trigger an interrupt on a low value, a
rising or falling edge, or a change in value. See the attachlnterrupt() function for details.

« PWM:3,5,6,9, 10, and 11. Provide 8-bit PWM output with the analogWrite() function.

e SPI: 10 (SS), 11 (MOSI), 12 (MISO), 13 (SCK). These pins support SPI communication, which,
although provided by the underlying hardware, is not currently included in the Arduino language.

e LED: 13. There is a built-in LED connected to digital pin 13. When the pin is HIGH value, the LED is
on, when the pin is LOW, it's off.


http://arduino.cc/en/Reference/AnalogWrite
http://arduino.cc/en/Reference/AttachInterrupt
http://arduino.cc/en/Reference/DigitalRead
http://arduino.cc/en/Reference/DigitalWrite
http://arduino.cc/en/Reference/PinMode
http://www.arduino.cc/en/Reference/EEPROM
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The Uno has 6 analog inputs, each of which provide 10 bits of resolution (i.e. 1024 different values). By
default they measure from ground to 5 volts, though is it possible to change the upper end of their range
using the AREF pin and the analogReference() function. Additionally, some pins have specialized
functionality:

+ I’C: 4 (SDA) and 5 (SCL). Support I’C (TWI) communication using the Wire library.
There are a couple of other pins on the board:

« AREF. Reference voltage for the analog inputs. Used with analogReference().
¢ Reset. Bring this line LOW to reset the microcontroller. Typically used to add a reset button to
shields which block the one on the board.

See also the mapping between Arduino pins and Atmega328 ports.

Communication

The Arduino Uno has a number of facilities for communicating with a computer, another Arduino, or other
microcontrollers. The ATmega328 provides UART TTL (5V) serial communication, which is available on
digital pins 0 (RX) and 1 (TX). An ATmega8U2 on the board channels this serial communication over USB
and appears as a virtual com port to software on the computer. The '8U2 firmware uses the standard USB
COM drivers, and no external driver is needed. However, on Windows, an *.inf file is required..

The Arduino software includes a serial monitor which allows simple textual data to be sent to and from the
Arduino board. The RX and TX LEDs on the board will flash when data is being transmitted via the USB-to-
serial chip and USB connection to the computer (but not for serial communication on pins 0 and 1).

A SoftwareSerial library allows for serial communication on any of the Uno's digital pins.

The ATmega328 also support 12C (TWI) and SPI communication. The Arduino software includes a Wire
library to simplify use of the 12C bus; see the documentation for details. To use the SPI communication,
please see the ATmega328 datasheet.

Programming

The Arduino Uno can be programmed with the Arduino software (download). Select "Arduino Uno w/
ATmega328" from the Tools > Board menu (according to the microcontroller on your board). For details,
see the reference and tutorials.

The ATmega328 on the Arduino Uno comes preburned with a bootloader that allows you to upload new code
to it without the use of an external hardware programmer. It communicates using the original STK500
protocol (reference, C header files).

You can also bypass the bootloader and program the microcontroller through the ICSP (In-Circuit Serial
Programming) header; see these instructions for details.

The ATmega8U?2 firmware source code is available . The ATmega8U2 is loaded with a DFU bootloader,
which can be activated by connecting the solder jumper on the back of the board (near the map of Italy) and
then resetting the 8U2. You can then use Atmel's FLIP software (Windows) or the DFU programmer (Mac
OS X and Linux) to load a new firmware. Or you can use the ISP header with an external programmer
(overwriting the DFU bootloader).


http://dfu-programmer.sourceforge.net/
http://www.atmel.com/dyn/products/tools_card.asp?tool_id=3886
http://dev.arduino.cc/wiki/uno/Hacking/Programmer
http://www.atmel.com/dyn/resources/prod_documents/avr061.zip
http://www.atmel.com/dyn/resources/prod_documents/doc2525.pdf
http://arduino.cc/en/Tutorial/Bootloader
http://arduino.cc/en/Tutorial/HomePage
http://arduino.cc/en/Reference/HomePage
http://arduino.cc/en/Main/Software
http://arduino.cc/en/Reference/Wire
http://www.arduino.cc/en/Reference/SoftwareSerial
http://arduino.cc/en/Hacking/PinMapping168
http://arduino.cc/en/Reference/AnalogReference
http://arduino.cc/en/Reference/Wire
http://arduino.cc/en/Reference/AnalogReference
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Automatic (Software) Reset

Rather than requiring a physical press of the reset button before an upload, the Arduino Uno is designed in a
way that allows it to be reset by software running on a connected computer. One of the hardware flow control
lines (DTR) of the ATmega8U2 is connected to the reset line of the ATmega328 via a 100 nanofarad
capacitor. When this line is asserted (taken low), the reset line drops long enough to reset the chip. The
Arduino software uses this capability to allow you to upload code by simply pressing the upload button in the
Arduino environment. This means that the bootloader can have a shorter timeout, as the lowering of DTR
can be well-coordinated with the start of the upload.

This setup has other implications. When the Uno is connected to either a computer running Mac OS X or
Linux, it resets each time a connection is made to it from software (via USB). For the following half-second or
so, the bootloader is running on the Uno. While it is programmed to ignore malformed data (i.e. anything
besides an upload of new code), it will intercept the first few bytes of data sent to the board after a
connection is opened. If a sketch running on the board receives one-time configuration or other data when it
first starts, make sure that the software with which it communicates waits a second after opening the
connection and before sending this data.

The Uno contains a trace that can be cut to disable the auto-reset. The pads on either side of the trace can
be soldered together to re-enable it. It's labeled "RESET-EN". You may also be able to disable the auto-reset
by connecting a 110 ohm resistor from 5V to the reset line; see this forum thread for details.

USB Overcurrent Protection

The Arduino Uno has a resettable polyfuse that protects your computer's USB ports from shorts and
overcurrent. Although most computers provide their own internal protection, the fuse provides an extra layer
of protection. If more than 500 mA is applied to the USB port, the fuse will automatically break the connection
until the short or overload is removed.

Physical Characteristics

The maximum length and width of the Uno PCB are 2.7 and 2.1 inches respectively, with the USB connector
and power jack extending beyond the former dimension. Three screw holes allow the board to be attached to
a surface or case. Note that the distance between digital pins 7 and 8 is 160 mil (0.16"), not an even multiple
of the 100 mil spacing of the other pins.



http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1213719666/all
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How fto use Arduino

Arduino can sense the environment by receiving input from a variety of sensors and can affect its
surroundings by controlling lights, motors, and other actuators. The microcontroller on the board is
programmed using the Arduino programming language (based on Wiring) and the Arduino
development environment (based on Processing). Arduino projects can be stand-alone or they can
communicate with software on running on a computer (e.g. Flash, Processing, MaxMSP).

Arduino is a cross-platoform program. You'll have to follow different instructions for your personal
OS. Check on the Arduino site for the latest instructions. http:/arduino.cc/en/Guide/HomePage

Linux Install Windows Install Mac Install

Once you have downloaded/unzipped the arduino IDE, you can Plug the Arduino to your PC via USB cable.

Blink led

Now you’re actually ready to “burn” your e ——
first program on the arduino board. To
select “blink led”, the physical translation
of the well known programming “hello
world”, select

int ledPin = 13; A4 LED comnected to digital pin 13
File>Sketchbook> /¢ The setupi) method runs once, when the sketch starts
Arduino-0017>Examples> void setwn() 1
P . A4 dnitialize the digital pin as an output:
Dlglta|>Bllnk pinfode (ledPin, DUTPSTJ: ’ ’
}
Once you have your Skecth you’” 44 the loopi) method runs over and ower again,

44 as long as the Arduino has power

see something very close to the

. woid 1o
screenshot on the right. et
digitalllrite(ledPin, HIGH): A4 set the LED on
delay (1000) A4 wait for a second
|n TOO|S>BOard SeleCt digitallirite (ledPin, LOW): /7 set the LED off
delay (1000} 2 A4 wait for a second

Now you have to go to
Tools>SerialPort

and select the right serial port, the
one arduino is attached to.

1% YR 1 YN

" a9=b | o 9°b o

° Done compiling. [I‘T
=

femaR

(to check for errors) TX RX Flashing Blinking Led!

Press Compile button



http://arduino.cc/en/Guide/HomePage
http://www.processing.org/
http://wiring.org.co/
http://arduino.cc/en/Reference/HomePage
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Dimensioned Drawing
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