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Read This First

If You Need Assistance

If you have any feedback or questions, support for the MSP430 device and the eZ430-RF2500 is provided
by the Texas Instruments Product Information Center (PIC) and the TI E2E Forum
(https://community.ti.com/forums/12.aspx). Contact information for the PIC can be found on the TI web site
at support.ti.com. Additional device-specific information can be found on the MSP430 web site,
www.ti.com/msp430.

NOTE: Support for the Solar Energy Harvesting Module

The Solar Energy Harvester module (SEH-01) is a product of Cymbet Corporation. For any
questions specifically on the SEH-01 module please contact Cymbet at www.cymbet.com or
+1-763-633-1780.

Related Documentation from Texas Instruments

The primary sources of MSP430 information are the device-specific data sheets and user's guides. The
most up-to-date versions of the user's guide documents available at the time of production have been
provided on the CD-ROM included with this tool. However, the most current information is found at
www.ti.com/msp430.

Information specific to the eZ430-RF2500-SEH development tool can be found at
http://focus.ti.com/docs/toolsw/folders/print/ez430-rf2500-seh.html.

MSP430 device user's guides and the FET user's guide (SLAU157) may be accessed on the included
CD-ROM under the User's Guides section. The FET user's guide includes detailed information on setting
up a project for the MSP430 using Code Composer Essentials.

FCC Warning

This equipment is intended for use in a laboratory test environment only. It generates, uses, and can
radiate radio frequency energy and has not been tested for compliance with the limits of computing
devices pursuant to subpart J of part 15 of FCC rules, which are designed to provide reasonable
protection against radio frequency interference. Operation of this equipment in other environments may
cause interference with radio communications, in which case, the user will be required to take whatever
measures may be required to correct this interference his own expense.

SimpliciTI is a trademark of Texas Instruments.
All other trademarks are the property of their respective owners.
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eZ430-RF2500-SEH Overview

1.1 Solar Energy Harvesting

The eZ430-RF2500-SEH is a complete Solar Energy Harvesting development kit to help create a
perpetually powered wireless sensor network based on the ultra-low-power MSP430 microcontroller.

The Solar Energy Harvesting module includes a high-efficiency solar (2.25 in x 2.25 in) panel optimized for
operating indoors under low-intensity florescent lights, which provides enough power to run a wireless
sensor application with no additional batteries. Inputs are also available for external energy harvesters
such as thermal, piezoelectric, or another solar panel.

The system also manages and stores additional energy in a pair of thin-film rechargeable EnerChips
which are capable of delivering enough power for 400+ transmissions. The EnerChips act as an energy
buffer that stores the energy while the application is sleeping and has light available to harvest. The
batteries are environmentally friendly and can be recharged thousands of times. They also have a very
low self discharge, which is vital for a no-power, energy harvesting system.

The eZ430-RF2500 is used to run the energy harvesting application. It is a complete USB-based MSP430
wireless development tool and provides all the hardware and software necessary to use the
MSP430F2274 microcontroller and CC2500 2.4-GHz wireless transceiver. It includes a USB debugging
interface that allows for real-time, in-system debugging and programming for the MSP430, and it is also
the interface to transfer data to a PC from the wireless system.

The integrated temperature and RF signal strength indicators can be used to monitor the environment,
and many external sensors can be used to collect additional data.

eZ430-RF2500-SEH Features
• Efficient solar energy harvesting module for the eZ430-RF2500
• Battery-less operation
• Works in low ambient light
• 400+ transmissions in dark
• Adaptable to any RF network or sensor input
• Inputs available for external harvesters (thermal, piezo, etc.)
• USB debugging and programming interface with an application backchannel to the PC
• 18 available analog and communications input/output pins
• Highly integrated, ultra-low-power MSP430 MCU with 16-MHz performance
• Two green and red LEDs for visual feedback
• Interruptible push button for user feedback
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Figure 1-1. eZ430-RF2500-SEH

1.2 Kit Contents, eZ430-RF2500-SEH
• Two eZ430-RF2500T wireless target boards
• One eZ430-RF USB debugging interface
• One AAA battery pack with expansion board (batteries included)
• One SEH-01-DK Solar Energy Harvesting Board
• One MSP430 Development Tool CD containing documentation and development software

– eZ430-RF2500-SEH Demo and Source Code, SLAC219
– eZ430-RF2500-SEH Development Tool User's Guide, SLAU273
– eZ430-RF2500 Development Tool User's Guide, SLAU227
– MSP430x2xx Family User's Guide, SLAU144
– MSP-FET430 Flash Emulation Tool (FET) (for Use With CCE v3.1) User's Guide, SLAU157
– Code Composer Essentials v3.1 Core Edition, SLAC063

NOTE: For the latest software and documentation visit
http://focus.ti.com/docs/toolsw/folders/print/ez430-rf2500-seh.html
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Figure 1-2. eZ430-RF2500-SEH Development Tool Features

1.3 Working with the eZ430-RF2500

For detailed information on the eZ430-RF2500 Wireless Development Tool, see its user's guide,
SLAU227.

The eZ430-RF2500 User Guide (SLAU227) includes the following information which is not covered in this
document:

• eZ430-RF2500T target board pinout
• MSP430F2274 and CC2500 specifications
• List of eZ430 emulator supported devices
• MSP430 application UART description
• Detailed eZ430-RF2500 hardware installation
• eZ430-RF2500 FAQ
• eZ430-RF2500 schematics and layout
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Getting Started

2.1 Prepare Solar Energy Harvester Module
1. Remove the 'Battery Enable Jumper', J8 (see Figure 1-2 for details).
2. Place the solar module in a well lit location for at least a few minutes prior to use. In average indoor

lighting, it may take up to one hour to fully charge the system, however, approximately five minutes
should be sufficient for initial startup.

2.2 Install Sensor Monitor Application and Drivers
1. Download the eZ430-RF2500-SEH Demo and Source Code (SLAC219) from the eZ430-RF2500-SEH

Development Tool web page or from the included CD.
2. Unzip the archive and run SEH-demo-setup-vx.x.exe.
3. Respond to the prompts to install the application.
4. Open the eZ430-RF2500-SEH Sensor Monitor program. A shortcut is available on the Desktop and in

the Start Menu under Programs > Texas Instruments > eZ430-RF2500-SEH Sensor Monitor.

2.3 Connect Hardware
1. Insert the eZ430-RF2500 into a USB port on the PC. This acts as the Access Point.

If prompted for the driver for the MSP430 Application UART, allow Windows to 'Install the software
automatically'. This is only possible if the Sensor Monitor has already been installed.
For more information, see Section 14: Detailed Hardware Installation Guide from the eZ430-RF2500
user's guide (SLAU227).
The Sensor Monitor PC application should now detect the MSP430 Application UART on the
appropriate COM port and the center bubble in the program blinks once a second.

2. Take the second eZ430-RF2500T target board and attach it to the Solar Energy Harvesting Module
(SEH-01) on connector J1. All components on the boards should be face up. A second bubble should
appear in the Sensor Monitor window representing the End Device. If the second bubble does not
appear, place the SEH-01 directly under a bright light for a few seconds and try again. Also try using
the battery pack to make sure the hardware is programmed properly.

3. By default, the End Device transmits every 10 seconds. Pushing the button on the End Device
changes the transmission duty cycle in the following intervals: 10 seconds, 20 seconds, 40 seconds, 2
minutes, 4 minutes and 5 seconds.

4. Try covering the solar panel to force the system run from the stored energy. The number of remaining
transmissions is displayed.

5. When finished, remove the eZ430-RF2500T End Device from the SEH-01 module, replace jumper on
J8, and close any open programs.

For troubleshooting tips, see Appendix A, Frequently Asked Questions.
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2.4 Install Code Composer Essentials

To edit and download code to the MSP430, Code Composer Essentials v3.1 or higher must be installed.

1. Download Code Composer Essentials Core Edition from www.ti.com/cce or from the included CD.
2. Extract the zip file and run the installation program.
3. Respond to the prompts to install the IDE.

NOTE: IDE Selection

The eZ430-RF2500-SEH firmware is provided for both Code Composer Essentials and IAR
Embedded Workbench, and the user has the option to select the IDE of their choice.
However, the firmware is larger than IAR KickStart's 4KB limit, so a full license of IAR
Workbench is required to compile the application using IAR. An evaluation version of IAR is
available from http://supp.iar.com/Download/SW/?item=EW430-EVAL.

This document describes working with only Code Composer Essentials.

2.5 Install the eZ430-RF2500-SEH Sensor Monitor Firmware Source

To edit the original energy harvesting project, the source code must be installed. A specific folder structure
is required, and it is recommended to leave the default install path. If it is not possible to install to the
recommended path, please note that additional steps are required to open the project for the first time.

1. Download the eZ430-RF2500-SEH Demo and Source Code (SLAC219) from the eZ430-RF2500-SEH
Development Tool web page or from the included CD.

2. Unzip the archive and run SEH-firmware-install-vx.x.exe.
3. Respond to the prompts to install the application.
4. Follow the steps described in Section 4.1.1 to download the firmware to the MSP430.
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Solar Energy Harvester Module (SEH-01)

3.1 Functional Description

The core technology behind the Solar Energy Harvesting module is the photovoltaic or solar cell that
converts ambient light into electrical energy. The energy from the solar cell must be converted, managed
and stored. This process is handled by the EnerChip EH CBC5300, the small DIP mounted board on the
Solar Energy Harvesting Module (SEH-01). A boost converter is used to increase the voltage from the
solar cell to a sufficient level to charge the thin-film battery and run the rest of the system.

The Charge Control block continuously monitors the output of the boost converter. If the output of the
boost converter falls below the voltage needed to charge the EnerChip, the charge controller disconnects
the boost converter from the system to prevent back powering the boost converter in low light conditions.

The Power Management block prevents the EnerChip from discharging too deeply in low-light conditions
or under abnormally high current loads. It also ensures that the load is powered up with a smooth
power-on transition. The Power Management block has a control line, CHARGE, which indicates to the
MSP430 that the solar energy harvester is actively charging the EnerChip. The control line input,
BATOFF, is available for the MSP430 to isolate itself from the EnerChip to conserve battery life in
prolonged low-light conditions.

The Solar Energy Harvesting Module features two EnerChip batteries mounted on the board with a
100-mAhr capacity and a 1,000-mF capacitor for high-current pulses during wireless transmissions.

Using the power management status and control signals on the SEH-01, the firmware on the MSP430 has
been written to make the application 'Energy Aware' to maximize the overall lifetime of the system.

Figure 3-1. Solar Energy Harvester Module (SEH-01) Block Diagram

3.2 Solar Energy Harvester Module (SEH-01) Figure and Description

Figure 3-2 shows the connections to the Solar Energy Harvester module.
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Figure 3-2. Solar Energy Harvester Module Connections

J1 Connector: Connection to the eZ430-RF2500T target board.

J5 Connector: Alternate connection point to power an external device or for measuring SEH-01 output
levels.

J7 Connector: Trace to cut if an alternate solar panel is connected to J8.

J8 Jumper: Battery enable jumper—the shunt must be removed before the module is charged. This
connector can also be used to connect an alternate solar panel to the SEH-01.

PT1 Connector: An alternate piezoelectric energy harvesting transducer can be connected. It can be
connected in parallel with the SEH-01 solar panel by leaving J7 intact or the piezoelectric transducer can
be used standalone by cutting the J7 trace.

CAUTION

The EnerChip EH CBC5300 module is mounted on a DIP socket that is
removable from the Solar Energy Harvesting (SEH-01) board. The pins on the
CBC5300 are fragile and care must be taken when removing the module.
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3.3 Solar Energy Harvester Module (SEH-01) Operating Characteristics

Table 3-1 shows the operating characteristics of the Solar Energy Harvester Module.

Table 3-1. SEH-01 Operating Characteristics

PARAMETER CONDITION MIN TYP MAX UNIT

Minimum operating lux 200 lux
Input luminous intensity (1)

Full charge rate 700 lux

Boost converter off 800 nA
Parasitic load current

Boost converter on 20 mA

1000 lux (FL), battery not charging 350 mWAverage output power
(measured at VOUT2 pin) 200 lux (FL), Battery not charging 80 mW

Output voltage, VOUT2 2-mA load, Battery charged 3.5 3.55 3.6 V

VBAT charging voltage 4.06 V

Battery cutoff voltage 3 3.3 3.6 V

Pulse discharge current 20 ms 30 mA

Self discharge rate (non-recoverable average) 25°C, Per year 2.5 %

Operating temperature 0 25 70 °C

10% depth-of-discharge 5000
25°CRecharge cycles 50% depth-of-discharge 1000

(to 80% of rated capacity,
10% depth-of-discharge 25004.1-V charge voltage) 40°C
50% depth-of-discharge 500

Recharge time (to 80% of rated capacity) 4.1-V constant voltage 500 min

Capacity 8-mA discharge; 25°C 100 mAh
(1) Fluorescent (FL) light conditions specifications subject to change without notice.

3.4 Solar Energy Harvester Module (SEH-01) Circuit Schematic

Figure 3-3 shows a schematic of the Solar Energy Harvester module.

Figure 3-3. Solar Energy Harvester Module Schematic
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3.5 Pulse Discharge Current for a Wireless End Device

High current pulses place special demands on batteries. Repeated delivery of pulse currents exceeding
the recommended load current of a given chemistry diminishes the useful life of the cell. The effects can
be severe, depending on the amplitude of the current and the particular cell chemistry and construction.
Pulse currents of tens of milliamperes are common in wireless sensor systems during transmit and receive
modes. Moreover, the internal impedance of the cell often results in an internal voltage drop that
precludes the cell from delivering the pulse current at the voltage necessary to operate the external circuit.

One method of mitigating such effects is to place a low equivalent series resistance (ESR) capacitor
across the battery. The battery charges the capacitor between discharge pulses, and the capacitor
delivers the pulse current to the load. Specifying the capacitance for a given battery in an application is a
straightforward procedure once a few key parameters are known. The key parameters are:

• Battery impedance (at temperature and state-of-charge)
• Battery voltage (as a function of state-of-charge)
• Operating temperatures
• Pulse current amplitude
• Pulse current duration
• Allowable voltage drop during pulse discharge

Two equations are used to calculate two unknown parameters:

• The output capacitance needed to deliver the specified pulse current of a known duration
• The latency time that must be imposed between pulses to allow the capacitor to be recharged by the

battery

Both formulas assume that the capacitor ESR is sufficiently low to result in negligible internal voltage drop
while delivering the specified pulse current; consequently, only the battery resistance is considered in the
formula used to compute capacitor charging time, and only the load resistance is considered when
computing the capacitance needed to deliver the discharge current.

The first step in creating a battery-capacitor couple for pulse-current applications is to size the capacitance
using the following formula:

Discharge formula: C = t / R × [–ln (Vmin / Vmax)]

Where:
C = output capacitance in parallel with battery
t = pulse duration
R = load resistance = VOUT(average) / Ipulse

Vmin and Vmax are determined by the combination of the battery voltage at a given state-of-charge and the
operating voltage requirement of the external circuit.

Once the capacitance has been determined, the capacitor charging time can be calculated using the
following formula:

Charge formula: t = R × C × [–ln (1 – Vmin / Vmax)]

Where:
t = capacitor charging time from Vmin to Vmax

R = battery resistance
C = output capacitance in parallel with battery

Again, Vmin and Vmax are functions of the battery voltage and the circuit operating specifications. Battery
resistance varies according to temperature and state-of-charge as described above. Worst-case
conditions are often applied to the calculations to ensure proper system operation over temperature
extremes, battery condition, capacitance tolerance, etc.
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eZ430-RF2500-SEH Sensor Monitor

The eZ430-RF2500-SEH Sensor Monitor is a full demonstration application that includes both the
firmware for the MSP430 that takes into consideration the constraints of running in an energy harvesting
environment as well as a PC application that can display all connected wireless nodes and the data that
they are reporting. Both the MSP430 firmware and the PC application (both binary and full source) are
included in SLAC219.

4.1 MSP430 Firmware

The eZ430-RF2500-SEH Sensor Monitor firmware is preloaded on the MSP430 devices and consists of a
wireless temperature sensor network and may be reprogrammed at any time. The network consists of an
Access Point that measures its own temperature and also receives data from End Devices. End Devices
measure their own temperature periodically and then enter low-power mode to reduce energy
consumption. The Access Point receives the information and transmits it to the PC through USB.
SimpliciTI™ is the RF network protocol used to establish the network. For more information on SimpliciTI,
visit www.ti.com/simpliciti.

4.1.1 Downloading Firmware to the MSP430

The firmware comes preloaded onto the MSP430 devices; however, it can be restored with the following
steps. The source code will be installed on the PC with the setup program included in SLAC219.

1. Open Code Composer Essentials v3.1.
2. Open any available Workspace.
3. Import the project to the Workspace.

(a) Click Project > Open Existing Project > Browse.
(b) Navigate to the source code location. The default location is

C:\Texas Instruments\eZ430-RF2500-SEH_Sensor_Monitor-v1.5\CCE_Source.
(c) Ensure "SEH Sensor Monitor" is selected under Projects.
(d) Click Finish.

4. Set up the Linked Resources.

(a) Navigate to Window > Preferences... > General > Workspace > Linked Resources.
(b) Click New...
(c) In the Name field enter "DEV_ROOT".
(d) Click the Folder… button and navigate to the source code installation root. The default location is

"C:\Texas Instruments\eZ430-RF2500-SEH_Sensor_Monitor-v1.5\CCE_Source".
If the Sensor Monitor demo is upgraded to a later version, the version number must be reflected in
the DEV_ROOT location.

(e) Click OK twice until the original CCE screen is displayed.
5. Connect one of the eZ430-RF2500T target boards to the eZ430 Emulator and plug it into a USB port

on the computer.
6. Right-click the project name "SEH Sensor Monitor" in the C/C++ Projects window and click Active Build

Configuration > End Device - Debug.
7. Click Project > Clean...
8. Click Run > Debug Active Project.
9. Click the Terminate button (red square in the top left 'Debug' view) to terminate the debugging session.
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10. Remove the eZ430-RF2500T target board from the emulator. It has now been programmed as the
End Device.

11. At the top right corner of the screen, click the C/C++ button to return to the C/C++ Programming
Perspective. Click the >> arrows if the button has moved off-screen.

12. Right-click the "SEH Sensor Monitor" project name in the C/C++ Projects window and select Active
Build Configuration > Access Point - Debug.

13. Click Project > Clean...
14. Click Run > Debug Active Project or click the green Run arrow button.
15. Connect the first eZ430-RF2500T (End Device) target board to the battery pack or the Solar Energy

Harvesting board.
16. Open the eZ430-RF2500 Sensor Monitor PC program installed on the PC to watch the network form

or receive data from the wireless node.

4.2 PC Sensor Monitor Application

The Sensor Monitor PC application is a graphical representation of the star network and displays the
sampled data from each wireless device. The center node is the Access Point and the attached nodes are
the End Devices, which display their temperature, voltage, and their transmission frequency. The physical
distance of the End Device from the Access Point is simulated on-screen by measuring the signal strength
(RSSI) of the received signal. The number of End Devices can be expanded by adding more wireless
nodes to the network as shown in Figure 4-1.

Figure 4-1. eZ430-RF2500-SEH Sensor Monitor

4.2.1 Energy Awareness

Because the End Devices are 'Energy Aware', they dynamically switch power sources from the solar cell
to the EnerChip if sufficient ambient light is not available to run the system. The node's color on the PC
Sensor Monitor window also displays its current power source. The node is yellow when powered from the
solar panel or the traditional battery back and is blue when running from the EnerChip.
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Copyright © 2009–2010, Texas Instruments Incorporated



Play

Pause

Stop
COM Port Selection

Console

Graph node data

User's guide

Configurations

About

www.ti.com PC Sensor Monitor Application

4.2.2 Remaining Transmissions

When running from the EnerChip, the application also display the number of transmissions left before the
stored energy is depleted. On average, ~400 transmissions are possible before the system needs to be
recharged.

4.2.3 Menu Bar

Figure 4-2 describes the eZ430-RF2500-SEH Sensor Monitor menu bar.

Figure 4-2. Menu Bar

4.2.3.1 Action Toolbar: Play, Pause, Stop

By default, the Sensor Monitor scans all available COM ports until it finds an MSP430 Application UART
and begins receiving data. The Play, Pause, and Stop controls are available to control the connection with
the COM port.

Play — Opens the MSP430 application UART COM port and resumes receiving data.

Pause — Closes the COM port, which stops the application from receiving data.

Stop — Closes the COM port, which stops the application from receiving data and clears the nodes from
the window.

4.2.3.2 Console Window

The console window (see Figure 4-3) is used to view a real-time output of all node data in text format.
Individual nodes, including the access point, can be removed from the console if necessary. This can be
useful when looking for a specific node's information. It is also possible to save the data in the console to
a text file for further analysis and processing.

Figure 4-3. Console Window
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4.2.3.3 Graph Window

Temperature data and RF signal strength (RSSI) for all nodes can be plotted in a graph (see Figure 4-4).
The signal strength is displayed as a percentage. The last 60 transmissions are stored and displayed.
Only 24 hours worth of data can be displayed.

Figure 4-4. Real-Time Node Data from the Graph Window

4.2.3.4 COM Port Selection

By default, the application selects and opens the first available MSP430 Application UART and refreshes
the drop down whenever a new COM port is available. This means it is rarely necessary to use the COM
port selection list unless multiple MSP430 Applications UARTs are available on the PC.

4.2.3.5 Configurations

Settings for the Sensor Monitor application can be changed in the configurations window. The default
temperature unit can be modified as well as the time required before a node is removed if a packet has
not been received in a while.

Figure 4-5. Configurations Window

20 eZ430-RF2500-SEH Sensor Monitor SLAU273C–January 2009–Revised May 2010

Copyright © 2009–2010, Texas Instruments Incorporated



www.ti.com PC Sensor Monitor Application

4.2.4 PC Sensor Monitor Application Source Code

The eZ430-RF2500-SEH Sensor Monitor application is open source and is licensed under GNU General
Public License v2. The source code is included in SLAC219. It was developed using the open source Qt
cross-platform applications framework, QWT, and compiled using Microsoft Visual C++ 2008 Express
Edition, which are all freely available. For detailed instructions on how to setup the environment to edit the
project, see the README.txt in the source code directory.
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Frequently Asked Questions

A.1 FAQs
1. My End Device doesn't join the network or it takes several tries to successfully join the

network?
The startup and network linking process is a very demanding from a power-consumption perspective,
because both the MSP430 and the CC2500 turn on in a full active mode at startup, which is a drain on
power when working with such a limited power budget. Also, linking to an RF network requires
scanning the area and exchanging packets between the ED and AP with the potential for
re-transmissions. High-current pulses, such as RF communication, are sourced from the 1000-mF
capacitor, and if all the energy is drained in a short period of time, it must be recharged prior by
holding the solar cell under a bright light prior to another attempt to join the network.

2. I've left the Solar Energy Harvesting Module under a bright light for three days, but it still
doesn't work in the dark?
The shunt on J8 must be removed to charge the EnerChip from the solar cell. With J8 in place, the
battery is isolated to prevent potential damage caused by it draining while in transport or storage.

3. Why does the Solar Energy Harvester Module use thin film rechargeable batteries instead of a
rechargeable AA, super cap, or other exotic storage solution?
Energy harvesting applications can also run from any other storage element. Thin film batteries have
the advantage of being easily recharged, have a small profile and, most importantly, have a negligible
self-discharge. Self discharge is the property of batteries or capacitors to lose charge over time;
however, thin film batteries lose only a small percentage of their charge over a long period of time.

4. Why is the battery pack included if the eZ430-RF2500T is intended to run from the Solar Energy
Harvester?
The battery pack is may be useful when trying to debug an application that has not been optimally
tuned to run in an efficient energy harvesting environment.

5. The reported temperature is incorrect, how can I calibrate the sensor?
A temperature offset is stored in Flash, which is calibrated at production. If the offset is erased or is
incorrect, it can be changed to an appropriate level for your application.

6. Where can I get the part number for the solar panel or the rest of build of material (BOM) for the
Solar Energy Harvesting module?
Please send all questions on the Solar Energy Harvesting Module to Cymbet (www.cymbet.com)

7. Where do I find more information on the eZ430-RF2500 wireless development tool?
The eZ430-RF2500 Development Tool User's Guide (SLAU227)

8. When I try to compile the source code with IAR Kickstart, I get the following error:
Fatal Error[e89]: Too much object code produced (more than 0x1000 bytes) for this package
IAR KickStart currently has a 4KB code size limitation, and the project being compiled is larger than
4KB. (0x1000 = 4096). To compile, a full license of IAR is required. A 30-day evaluation version of IAR
is available from http://supp.iar.com/Download/SW/?item=EW430-EVAL.
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9. When I try to compile the source code with Code Composer Essentials with a version prior to
3.1 (build 3.2.3.6.4), I get the following error:
undefined first referenced symbol in file --------- ---------------- __delay_cycles ./Peer

Applications/SEH_ED_v1.3.obj

The __delay_cycles intrinsic was introduced with Code Composer Essentials v3.1, and prior to this
release, the CCE code generation tools cannot process the statement. You can either upgrade to CCE
v3.1+ or remove the __delay_cycles intrinsic and replace with the following for-loop:
int i; for (i = 0; i < 250; ++i) { }

10. Why is the solar panel on the energy harvesting board so large when my TI-36X works fine
with a tiny solar panel?
The current required to run a calculator and LCD is relatively small. Running a wireless sensor
network, however, consumes approximately 10 mA to 25 mA when trying to simultaneously sample
sensors and transmit data wirelessly. This current might be 100 to 1,000 times more than a calculator
application. A larger solar panel allows collection of more solar energy to keep up with the real-time
demands of a wireless system with a high duty cycle. The design could be optimized with a smaller
solar cell, but the frequency of RF transmissions would have to be reduced significantly.
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IMPORTANT NOTICE

Texas Instruments Incorporated and its subsidiaries (TI) reserve the right to make corrections, modifications, enhancements, improvements,
and other changes to its products and services at any time and to discontinue any product or service without notice. Customers should
obtain the latest relevant information before placing orders and should verify that such information is current and complete. All products are
sold subject to TI’s terms and conditions of sale supplied at the time of order acknowledgment.

TI warrants performance of its hardware products to the specifications applicable at the time of sale in accordance with TI’s standard
warranty. Testing and other quality control techniques are used to the extent TI deems necessary to support this warranty. Except where
mandated by government requirements, testing of all parameters of each product is not necessarily performed.

TI assumes no liability for applications assistance or customer product design. Customers are responsible for their products and
applications using TI components. To minimize the risks associated with customer products and applications, customers should provide
adequate design and operating safeguards.

TI does not warrant or represent that any license, either express or implied, is granted under any TI patent right, copyright, mask work right,
or other TI intellectual property right relating to any combination, machine, or process in which TI products or services are used. Information
published by TI regarding third-party products or services does not constitute a license from TI to use such products or services or a
warranty or endorsement thereof. Use of such information may require a license from a third party under the patents or other intellectual
property of the third party, or a license from TI under the patents or other intellectual property of TI.

Reproduction of TI information in TI data books or data sheets is permissible only if reproduction is without alteration and is accompanied
by all associated warranties, conditions, limitations, and notices. Reproduction of this information with alteration is an unfair and deceptive
business practice. TI is not responsible or liable for such altered documentation. Information of third parties may be subject to additional
restrictions.

Resale of TI products or services with statements different from or beyond the parameters stated by TI for that product or service voids all
express and any implied warranties for the associated TI product or service and is an unfair and deceptive business practice. TI is not
responsible or liable for any such statements.

TI products are not authorized for use in safety-critical applications (such as life support) where a failure of the TI product would reasonably
be expected to cause severe personal injury or death, unless officers of the parties have executed an agreement specifically governing
such use. Buyers represent that they have all necessary expertise in the safety and regulatory ramifications of their applications, and
acknowledge and agree that they are solely responsible for all legal, regulatory and safety-related requirements concerning their products
and any use of TI products in such safety-critical applications, notwithstanding any applications-related information or support that may be
provided by TI. Further, Buyers must fully indemnify TI and its representatives against any damages arising out of the use of TI products in
such safety-critical applications.

TI products are neither designed nor intended for use in military/aerospace applications or environments unless the TI products are
specifically designated by TI as military-grade or "enhanced plastic." Only products designated by TI as military-grade meet military
specifications. Buyers acknowledge and agree that any such use of TI products which TI has not designated as military-grade is solely at
the Buyer's risk, and that they are solely responsible for compliance with all legal and regulatory requirements in connection with such use.

TI products are neither designed nor intended for use in automotive applications or environments unless the specific TI products are
designated by TI as compliant with ISO/TS 16949 requirements. Buyers acknowledge and agree that, if they use any non-designated
products in automotive applications, TI will not be responsible for any failure to meet such requirements.

Following are URLs where you can obtain information on other Texas Instruments products and application solutions:

Products Applications

Amplifiers amplifier.ti.com Audio www.ti.com/audio

Data Converters dataconverter.ti.com Automotive www.ti.com/automotive

DLP® Products www.dlp.com Communications and www.ti.com/communications
Telecom

DSP dsp.ti.com Computers and www.ti.com/computers
Peripherals

Clocks and Timers www.ti.com/clocks Consumer Electronics www.ti.com/consumer-apps

Interface interface.ti.com Energy www.ti.com/energy

Logic logic.ti.com Industrial www.ti.com/industrial

Power Mgmt power.ti.com Medical www.ti.com/medical

Microcontrollers microcontroller.ti.com Security www.ti.com/security

RFID www.ti-rfid.com Space, Avionics & www.ti.com/space-avionics-defense
Defense

RF/IF and ZigBee® Solutions www.ti.com/lprf Video and Imaging www.ti.com/video

Wireless www.ti.com/wireless-apps
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