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| Reader’s note |

DISCLAIMER:

mikroBasic and this manual are owned by mikroElektronika and are protected by copyright
law and international copyright treaty. Therefore, you should treat this manual like any other
copyrighted material (e.g., a book). The manual and the compiler may not be copied, par-
tially or as a whole without the written consent from the mikroElektronika. The PDF-edition
of the manual can be printed for private or local use, but not for distribution. Modifying the
manual or the compiler is strictly prohibited.

HIGH RISK ACTIVITIES

The mikroBasic compiler is not fault-tolerant and is not designed, manufactured or intended
for use or resale as on-line control equipment in hazardous environments requiring fail-safe
performance, such as in the operation of nuclear facilities, aircraft navigation or communica-
tion systems, air traffic control, direct life support machines, or weapons systems, in which
the failure of the Software could lead directly to death, personal injury, or severe physical or
environmental damage ("High Risk Activities"). mikroElektronika and its suppliers specifically
disclaim any express or implied warranty of fitness for High Risk Activities.

LICENSE AGREEMENT:

By using the mikroBasic compiler, you agree to the terms of this agreement. Only one
person may use licensed version of mikroBasic compiler at a time.

Copyright © mikroElektronika 2003 - 2007.

This manual covers mikroBasic for dsPIC30/33 and PIC24 version 5.0 and the related top-
ics. New versions may contain changes without prior notice.

COMPILER BUG REPORTS:
The compiler has been carefully tested and debugged. It is, however, not possible to
guarantee a 100% error free product. If you would like to report a bug, please contact us at
the address support@mikroe.com. Please include the following information in your bug
report:

- Your operating system

- Version of mikroBasic

- Code sample

- Description of a bug

CONTACT US:

mikroElektronika

Voice: + 381 (11) 30 66 377, + 381 (11) 30 66 378
Fax: + 381 (11) 30 66 379

Web:  www.mikroe.com

E-mail: office@mikroe.com

Support: support@mikroe.com

dsPIC30/33 and PIC24, PICmicro and MPLAB is a Registered trademark of Microchip com-
pany. Windows is a Registered trademark of Microsoft Corp. All other trade and/or services
marks are the property of the respective owners.
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- k
ATAYAYA

mikroBasic IDE

QUICK OVERVIEW

mikroBasic is a powerful, feature rich development tool for dsPIC30/33 and
PIC24 micros. It has been designed to provide the customer with the easiest possi-
ble solution for developing applications for embedded systems, without compro-
mising performance or control.

Highly advanced IDE, broad set of hardware libraries, comprehensive

documentation and plenty of ready to run examples should be more than enough
to get you started in programming dsPIC30/33 and PIC24 microcontrollers.
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Assistant

mikroBasic for dsPIC30/33 and PIC24 is an user-friendly and
intuitive environment:

- The Code Editor features adjustable Syntax Highlighting, Code Assistant,
Parameters Assistant, Auto Correct for common typos and Code Templates
(Auto Complete).

- The Code Explorer (with Keyboard shortcut browser and Quick Help browser)
is at your disposal for easier project management.

- The Error Window displays all errors detected during compiling and linking.

- The source-level Software Simulator lets you debug executable logic
step-by-step by watching the program flow.

- The New Project Wizard is used to create a project in a fast, reliable,
and easy way.

- Help files are syntax and context sensitive.

- Like in any modern Windows application, you may customize the layout
of mikroBasic for dsPIC30/33 and PIC24 to suit your needs best.
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CODE EDITOR

The Code Editor is an advanced text editor fashioned to satisfy needs of profes- 3
sionals. General code editing is the same as working with any standard text-editor,
including familiar Copy, Paste and Undo actions, common for Windows environ-
ment.

Advanced Editor Features:

- Adjustable Syntax Highlighting

- Code Assistant

- Parameter Assistant

- Code Templates (Auto Complete)
- Auto Correct for common typos

- Bookmarks and Goto Line

E You can configure the Syntax Highlighting, Code Templates and Auto Correct
from the Editor Settings dialog. To access the Settings, click Tools » Preferences
from the drop-down menu, click the Preferences Icon or press F12 key.

Tools Icon.

B Preferences
= Edilee
Ciokous Scheme: | Zedar o :
Auito Conect Iﬂ"‘" S':hnmel | Dielete ]
fusto Complete: = 4 2
Coommesls gﬂ#'y l 3
Took: Float 4
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Sesrch Path Iderklies €
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Muriber 8
Preprocassor 5
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Space io
Shirg 11 $10101010
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Code Assistant [CTRL+SPACE]
4
If you type the first few letters of a word and then press Ctrl+Space, all valid iden-
o tifiers matching the letters you have typed will be shown in a floating panel (see
(<)) the image below). Now you can keep typing to narrow the choice, or you can
S_ select one from the list using the keyboard arrows and Enter.
[ ]

we]

sub procedure main e
const MAX_LOMGINT = 2147483647, —
const MAX WORD = G55535,

const MAx INTEGER = 22767,

const MAX_EXPOMENT = 255,

zub procedure Man_5Send [data az bute]
zub procedure Manchester_0ut [BitYalue as ward)
zub procedure Man_Send_Config [ byref port as ward, tepin as word) W

Parameter Assistant [CTRL+SHIFT+SPACE]

The Parameter Assistant will be automatically invoked when you open parenthesis
“(” or press Shift+Ctrl+Space. If the name of a valid function precedes parenthe-
sis, then the expected parameters will be displayed in a floating panel. As you type
the actual parameter, the next expected parameter becomes bold.

channel as word

Ade Read ||

mikroElektronika mikroBasic for dsPIC30/33 and PIC24



——= \ [ : feddececcefose

=

Tools Icon.

Routines List
5
If you press Ctrl+L, the Routines List Window will appear. All valid functions and
procedures will be listed in this window (see the image below). Select the routine )
and double-click it or press Enter to move to the definition of the selected routine. g
Q
[ ]

[B] Routines List |Z| |E| |E|

Foutine Type Line
Zero_Fill 30
Firtrirn 38
Fead_Time X}
Tranzform_Time B8
Dizplay_Time 78
Init_k ain 108

Code Templates [CTR+J]

You can insert the Code Template by typing the name of a template (for instance,
proc), then press Ctrl+J and the Code Editor will automatically generate a code.

You can add your own templates to the list. Select Tools » Preferences from the
drop-down menu, or click the Preferences Icon and then select the Auto Complete
Tab. Here you can enter the appropriate keyword, description and code of your
template.
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Tools Icon.

0

Comment /
Uncomment Icon.

Auto Correct

The Auto Correct feature corrects common typing mistakes. To access the list of
recognized typos, select Tools > Preferences from the drop-down menu, or click
the Preferences Icon and then select the Auto Correct Tab. You can also add your
own preferences to the list.

Comment/Uncomment

Also, the Code Editor has a feature to comment or uncomment the selected code
by simple click of a mouse, using the Comment Icon and Uncomment Icon from
the Code Toolbar..

Bookmarks

Bookmarks make navigation through a large code easier.

To set a bookmark, use Ctrl+Shift+number.

To jump to a bookmark, use Ctrl+number.

Goto Line

The Goto Line option makes navigation through a large code easier.
Use the shortcut Ctrl+G to activate this option.
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CODE EXPLORER
7
The Code Explorer is placed to the left of the main window by default and gives
clear view of each item declared inside the source code. You can jump to a decla- o
ration of any item by double clicking it. To expand/collapse the treeview in the g
Code Explorer, use the icon . o
[ ]

Also, there are two more tab windows available in the Code Explorer. QHelp Tab
E} lists all available built-in and library functions, for a quick reference. Double-
Collapse/Expand clicking a routine in the QHelp view opens the relevant Help topic. The Keyboard

All Icon. Tab lists all available keyboard shortcuts in mikroBasic for dsPIC30/33 and
PIC24.

| 1|
Code Explorer | GHelp | Keyboard |
¥E @

= include

“M Lib_Gled_Images"

=8 m_ain
=- wariables

someTexk
- Delay2s
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Software Simulator

@

Start Debugger.

The Source-level Software Simulator is an integral component of the mikroBasic
for dsPIC30/33 and PIC24 environment. It is designed to simulate operations of
the Microchip dsPIC30/33 and PIC24 MCUs and assist the users in debugging
Basic code written for these devices.

After you have successfully compiled your project, you can run the Software
Simulator by selecting Run » Start Debugger from the drop-down menu, or by
clicking the Start Debugger Icon . Starting the Software Simulator makes more
options available: Step Into, Step Over, Step Out, Run to Cursor, etc. Line that is
to be executed is color highlighted (blue by default).

Note: The Software Simulator simulates the program flow and execution of
instruction lines, but it cannot fully emulate dsPIC30/33 and PIC24 device behav-
ior, i.e. it doesn’t update timers, interrupt flags, etc.

o Function
Name Description Key
start Start Software Simulator. [F9]
Debugger
Run/Pause Run or pause Software Simulator. [F6]
Debugger
Stop Debugger | Stop Software Simulator. [Ctrl+F2]

Toggle breakpoint at the current cursor position. To

view all breakpoints, select Run > View

Breakpoints from the drop-down menu. Double [F5]

clicking an item in the Breakpoints Window List

locates the breakpoint.

Execute all instructions between the current

Run to cursor | . . .. [F4]
instruction and cursor position.

Execute the current Basic (single or multi—cycle)

instruction, then halt. If the instruction is a routine

Toggle
Breakpoints

St Int . . F7
ep Anto call, enter the routine and halt at the first instruc- [F7]
tion following the call.
Step Over Execute. the current Basic (single or multi—cycle) [F8]
instruction, then halt.
Step Out Execute all remaining instructions in the current [Ctrl+F8]

routine, return and then halt.
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Watch Window
9
The Software Simulator Watch Window is the main Software Simulator window
which allows you to monitor program items while simulating your program. To v
show the Watch Window, select View > Debug Windows » Watch Window from g
the drop-down menu. o
[ ]

The Watch Window displays variables and registers of the MCU, along with their
addresses and values.

There are two ways of adding variable/register to the watch list:

&oadd | - by its real name (variable's name in "Basic" code). Just select desired
ADD Bution variable/register from Select variable from list drop-down menu and click the
Add Button .

- by its name ID (assembly variable name). Simply type name ID of the

variable/register you want to display into Search the variable by assemby name
box and click the Add Button .

' Remove  Variables can also be removed from the Watch Window, just select the variable
Remove Button  that you want to remove and then click the Remove Button.

|E| Watch
|<>nd>(,nq>1>j[||i|ﬁﬁ
a. add Remove Properties & Add all @. Remave Al
Select variable from list:
|enable W |
Search for variable by assembly name:
s
Marne value Address
(ADPCFG | Ob1111 1111 11111111 Ox02A8 |
TRISD 1] Ox0zD2
B bxt I 0x0C22
)] 2 0x0C22
[1] o 00C23 = |
] o 0x0C24
I3 o 0%0C25
[4] Kt 0%0C26
[5] o 0%0C27
I2CTRM 1] 00202
I2CRCY a 00200 :ll
PC= O0x000B65 Time= 164,35 ms J
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10 | & add &l Add All Button adds all variables.

Add All Button

v .
g [ Remove al  Remove All Button removes all variables.
Q.

Remove All Button

¢ You can also expand/collapse complex variables, i.e. struct type variables,

strings...

Values are updated as you go through the simulation. Recently changed items are
colored red.

Ly Properties Double clicking a variable or clicking the Properties Button opens the Edit Value
window in which you can assign a new value to the selected variable/register.
Also, you can choose the format of variable/register representation between deci-
mal, hexadecimal, binary, float or character. All representations except float are
unsigned by default. For signed representation click the check box next to the
Signed label.

Properties Button

An item's value can be also changed by double clicking item's value field and typ-
ing the new value directly.

[B] Edit Value: ADPCFG A=

| 0000 O0FF |

Representation

{JDec {®) Hex I Bin ) Float ) Char

[ Signed [, Ok, ,] ’ Cancel l
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Stopwatch Window
1
The Software Simulator Stopwatch Window is available from the drop-down
menu, View > Debug Windows > Stopwatch. o
o
©
The Stopwatch Window displays a current count of cycles/time since the last o
[ ]

Software Simulator action. Stopwatch measures the execution time (number of
cycles) from the moment Software Simulator has started and can be reset at any
time. Delta represents the number of cycles between the lines where Software
Simulator action has started and ended.

Note: The user can change the clock in the Stopwatch Window, which will recal-
culate values for the latest specified frequency. Changing the clock in the
Stopwatch Window does not affect actual project settings — it only provides a sim-

ulation.
|E| Stopwatch
Cyiles: Time:
Current Count: |43 | |2.15 us |
Delta: < | [roous |
Stopwatch: |33 | |1.90 us |
Close
RAM Window

The Software Simulator RAM Window is available from the drop-down menu,
View > Debug Windows > RAM.

The RAM Window displays a map of MCU’s RAM, with recently changed items
colored red. You can change value of any field by double-clicking it.
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ERROR WINDOW
13
In case that errors are encountered during compiling, the compiler will report them
and won’t generate a hex file. The Error Window will be prompted at the bottom o
of the main window by default. g
Q
The Error Window is located under message tab, and displays location and type of ¢

errors the compiler has encountered. The compiler also reports warnings and hints,

but these do not affect the output. Only errors can interefere with the generation of
hex.

Messages Conven0r|

Line/Coluran | Message Mo, | Message Text | Unit
215 Hirk: Yariable ' has been declared, but not used LCD4BitTest, dbas
_ Identifier  was not declareg
4614 Synkax error: Expected 'end LCD4EiTest.dbas
4711 E 4 Synkax error: Expected ', bul LCD4EitTest.dbas
£ 1ill ] 2|

Double click the message line in the Error Window to highlight the line where the
error has been encountered.

Right-Click the message line to enable copying the message text to Clipboard.

For more information on errors recognized by the compiler consult the Error
Messages.

mikroElektronika mikroBasic for dsPIC30/33 and PIC24



STATISTICS

i After successful compilation, you can review statistics of your code. Select
o View » View Statistics from the drop-down menu, or click the Statistics Icon .
(o)) Statistics Icon. L here are five tab windows:
©
Q

¢ Memory Usage Window
Provides overview of RAM and ROM usage in form of histogram.

|E| Statistics,

| Procedures (sizes] || Procedures (locations) | RidM | ROM |

RAM Memory Usage (locations) ROM Memory Usage (ocations)

03 2,576 Frae RAM
33 Used RAM

31,366 Free ROM
1,400 Used ROM

Free RAM Used RAM Free ROM Lzed ROM

Procedures (Graph) Window
Displays procedures and functions in form of histogram, according to their memo-
ry allotment.

[B] statistics

Hemary usage || Procedures [sizes) | Frocedures (locations) | RéM | ROM |

ROM usage by procedure (ROM locations)

mzin
Delay_Cyo
Led_Cut
Led_Out_CP
Led_Chr_CP
Ledd_Crmit
Delay_S0US
Delay_5500us
_Strobe;
Delay_1uS

Leil_init_EasyDsPIC3

Led_nit

20 40 B0 81 100 120 140 160 180 200 220 240 280 280 300
ROM locations
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Procedures (Locations) Window
Displays how procedures and functions are distributed in microcontroller’s memo-

ry.

-
(3]

page

Procedures by ROM location

main
Delay_Cyc

Led_Out
Led_Out_CP
Lod_Chr_GP
Leid_Crnid
Delay_S0US
Delay_5500us
_Strobe

Defay_1us
Led_Inft_EasyDsPICE

Led_Init

ROM Address

RAM Window
Summarizes all GPRs and SFRs and their addresses. It also displays symbolic
names of variables and their addresses.

|E| Statistics,

Memary usage | Frocedures (sizes) | Frocedures [locations] ¢

General purpose registers [GPRA) Special function registers (SFR)
Address Register Address Register
Ox0CE2 0x0000
0x0CE4 __lib_ledeustom  mdbE 0x0002 Ll
0x0CEB __lib_ledeustom_ mdhS 0x0004 W2
0x0CEE __lib_ledeustom____mdbd <0006 W3
0x0CER __lib_ledeustom__mrs: 0x0002 Wid
0x0CEC __lib_ledeustom_ mnw 0x0004, W5
0x0CEE __lib_lcdeustom____menable Ox000C W
0x0C70 __lib_ledeustom_datalat 0x000E WiT
0x0C72 __lib_ledeustom_chillst 0x0010 Wil
0<0C74 __lib_lcdeustom_lcdemdstatus Ox0012 W9
0x0C76 __lib_ledeustom_tmpdata 0:0014 W10
0x0C78 bt [ tat] 0x0016 W11
OxFFFFFFFF|db0 (FARG_Lcd_lrit_4) 0:0018 W12
OxFFFFFFFF | ctrl_port [FARG_Led Init_5) 0x0014, W13
0xFFFFFFFF|db1 (FARG_Led_Init_3) 0x001C W14
OxFFFFFFFF|db3 (FARG_Lcd_lit_1) 0:001E W15
OxFFFFFFFF|db2 (FARG_Lcd_lnit_2) 0x02C8 PORTE
0xFFFFFFFF | diris [_lcd_init_local_diris] - 0x0204
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ROM Window
16 Lists op-codes and their addresses in form of a human readable hex code.

Q Memery usage | Frocedures [sizes) | Fracedures [locations) | Ram |EHOM
m $00FE §FFFFFF NOPR =
m §00FL §FFFFFF NOPR
Q §00FC §FFFFFF NOPR
$00FE $FFFFFF NOFR
° §0100 §FADOD4 LNK #4
§0102 §0700BE RCALL _delay_5500us I
§0104 §0700B7 RCALL  _delay_5500us T
$0106 §0700B6 RCALL _delay_5500us
§0108 $97BEEE MOV [Wi4+-10], W1
0104 §200010 MOV #1, W0
s010C $DDO301 SL wa, Wi, We
§010E $886006 MOV WE, _ lib_ledcustom mdb?
50110 §97BSAE MOV [Wi4+-12], W1
§0112 4200010 MOV #1, WO
0114 $DDOZS1 SL wa, Wi, WS
§0118 §886015 MOV WS, _ lib_ledeustom ol &
$0116 $97B89E MOV [W14+-14], Wi
§0114 $200010 MOV #1, WO
§011C §DD0201 3L wo, Wi, w4
$011E §806024 MOV W4, _ lib_ledoustom pillel =p}
0120 $97B38E MOV [W144-16], W1
§0122 §200010 MOV #1, W0
50124 §DDOLE1 SL wo, Wi, w3
§0126 $886033 MOV W3, _ lib_ledoustom mdb4 =

mikroElektronika mikroBasic for dsPIC30/33 and PIC24



==\ \__

INTEGRATED TOOLS

@ USART

USART
Terminal

Terminal

Icon Tools » USART Terminal or by clicking the Terminal Icon.

== Communication Terminal

Settings
Com Port; | CORT
Baud: 9600
Stop Bits: One Stop Bit
Parity: None
[] Check Parity
Data bits: | Eight
Commands
RIS DTR
(2 Off () 0ff
()0n ()0n
Status

Send Receive CTS DSA

L% L [*] L
Log Files
Read from: 3|
WTike bo: | S|
T Create file

automatically

Communication

mikroBasic for dsPIC30/33 and PIC24 includes the USART communication termi-
nal for RS232 communication. You can launch it from the drop-down menu

|Echo |[ Send ] Send File
Append: [ CR [ Send as tping Start Logging
LF [ send as number
Farmat
(=) A5 () HE= () DEC
Connected to COM1
Sent: Echa

Received: Echo

LClose

-_—
N

page
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18 ASCII Chart

@ The ASCII Chart is a handy tool, particularly useful when working with LCD dis-
o ascii play. You can launch it from the drop-down menu Tools > Ascii chart or by click-
= Chart - ing the View ASCII Chart Icon.

Q.

Icon

fi# ASCII Chart

0 1 2 3 4 5 o) 7 8 a A B C D E F
0 NUL |[SOH|STX ETX (EOT ENQ |ACK |BEL | BS |HT | LF | ¥T | FF |CR |50 | 5I
1] 1 2 3 4 5 & 7 e el 10 11 12 13 14 15
1 DLE (DC1 |DC2 DCZ DC4 |NAK |SYMN ETB [CAN| EM SUB ESC | FS | GS (RS | US
16 17 13 19 20 21 22 23 24 25 26 27 28 20 a0 3l
2 SPC| ! = # L . { )] o + . = . &
a2 33 a4 35 36 a7 38 39 40 41 42 43 44 45 46 47
3 1] 1 2 3 L o t i 8 a 2 . < = = 7
43 | 49 50 51 52 53 54 =t =] 57 53 50 G0 =)} 62 63
4 1] A B C D E F G H I ] K L M1 i (1]
o4 ; i) [=]:] o7 6 [=E) 70 7l 72 73 74 7o Th 77 78 79
= A
5 P 0 G T u Y W X ¥ i [ ", 1 -
i) Gl DEC: 65 04 =] i) a7 ] 49 a0 91 92 93 94 a5
T aHER: Ox4l d e | f g h|i i |k Il 'm n | o
6 BIM: 0100 0001
96 a7 101 | 10z | 103 | 104 | 105 | 106 | 107 | 105 | 109 | 110 | 111
- p u v o W | X ¥ | 2 { | ¥  ~ |DEL
112 | 115 | 114 | 115 | 116 | 117 | 115 | 119 120 | 121 | 122 | 123 | 124 | 125 | 126 | 127
g €0, | F w1 |¥] " %5 « | &[0 2 O
128 | 129 [ 130 | 131 [ 132 | 1353 [ 134 | 135 | 1536 | 137 | 135 | 139 | 140 [ 141 | 142 | 143
5 I el g = =™ &y e O F Y
144 | 145 [ 146 | 147 [ 145 | 149 [ 150 | 151 | 152 | 153 | 154 | 155 | 156 [ 157 | 155 IE?
A i ¢ | E | 8O | ¥ H § T @ |8 |« | 2| - | ®
160 | 161 (162 | 163 [ 164 | 165 [ 166 | 167 | 168 | 169 | 170 | 171 | 172 [ 173 | 174 [ 175
T R N AR
176 | 177 | 178 | 179 | 180 | 181 | 162 | 183 | 184 | 185 | 186 | 187 | 185 | 189 | 190 | 191
C A A A A A A | E C E E E E 1 1 I I
192 | 193 [ 194 | 195 [ 196 | 197 [ 195 | 199 | 200 | 201 | 207 | 203 | 204 | 2056 | 206 | 207
D B I 0 0 (] 0 (] ® [h] u u u u Y p ]
208 [ 209 | 210 [ 211 | 212 | 213 | 214 | 215 | 216 | 217 [ 218 | 219 | 220 | 221 | 222 | 223
E a/4a4 a &ad|a|ld|le| c & |8&|a) e i i i )
224 | 225 | 226 | 227 | 228 | 229 | 230 | 231 | 232 | 233 | 234 | 235 | 236 | 237 [ 238 | 239
F d | A |6 |06 06|60+ & 0| a a0 |y | p|¥
240 [ 241 | 242 [ 243 | 244 | 245 | 246 | 247 | 248 | 240 | 250 | 251 | 252 | 253 | 254 | 255
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7 Segment Display Decoder 19

The 7 Segment Display Decoder is a convenient visual panel which returns deci-

mal/hex value for any viable combination you would like to display on 7seg. Click )

on the parts of 7 segment image to get the requested value in the edit boxes. You g

can launch it from the drop-down menu Tools > Seven Segment Decoder. o
[ ]

I segment display decoder D__<|

Common cathode

$ED

Common anode

—
— 912
—

Decode in;

" decimal value

(¢ hexvalue

Cloze
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20 Filter Designer

The Filter designer is a tool for designing FIR and IIR filters. It has an user-friend-
o ly visual interface for setting filter parameters. Filter designer output is mikroBasic
o for dsPIC30/33 and PIC24 compatible code. You can launch it from the drop-

g down menu Tools > Filter Designer Tool.

[B] Filter, designer tool

=-FIR Device Setup Input Signal
FIR Parame §
- FIR Window Device: | PAOFEDT4 v Gampling frequency: (20000 Hz
- FIR Freguency =
=- 1R Clock: |180.000000 tHz ADC Input Channel 10 [=]
IR Parameters
IR Prototype y
IR Frequency Filter Setup A (4B
=~ Source Code Filter type: Wpass: |4000 Hz
mikroPascal
- mikroB asic Filter arder. |20 =]
e Thikral 0 EA
P30FEDT4
- P20F4012 Rectangular: Lowest attenuation in stopband,
Highest nzcillations in pazshand and
nanowest ransition zone [2Fs/M, where fs is sampling frequency
and M iz filker order).

VVpéss

FIR filters are characterized by & linear phase and by a constant group delay.
The bad side is a high order of the filker which means higher complexity.
Alinear phase characteristicis the main acvantage of FIR filters.

If & linear phase is not an issue, FIR filters are nota good choice

Instead, IR filters have much lower arder with almost the same effects.

Howewer, IR filters have awvery non-linear phase characteristic.
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MANUAL
UDP Terminal 21
mikroBasic for dsPIC30/33 and PIC24 includes the UDP Terminal. You can
launch it from the drop-down menu Tools » UDP Terminal. o
g
Q.
=5 UDP Communication Terminal ®

—Setting
IP Address: [192.168.20.60 Connect |

Part: |1 iy

—Send:

ImikrDEIektanika . send I
&ppend: [~ CR [~ Send as typing
[ LF [~ Send as: number

mikroE lek tranik.a
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22 Graphic LCD Bitmap Editor

mikroBasic for dsPIC30/33 and PIC24 includes the Graphic LCD Bitmap Editor.
o Output is mikroBasic for dsPIC30/33 and PIC24 compatible code. You can launch
g» it from the drop-down menu Tools » GLCD Bitmap Editor.

Q.

mikroElektronika Graphic LCD Bitmap generator &
KS0108 [ 15353 || Makiaz110|

A R
File: loaded: truck.bmp {jzjiﬁiﬁizj Tt
Ficture preview —128x64 pix | bw - ol Ve

[ Load EMP Picture ]

( Create CODE |

[lﬂlllﬂlllllllﬂllﬂl]

[ mwetprcre |

GLCD Size | controller
240128 (nok imp, yet)
24064 (nok imp, yek)
128x128 (not imp. yet)

(3) 128x64 (K50108)
128%32 (nok imp. ywek)

i

* GLCD Picture name: truck.bmp
: GLCD Model: KSA188 128x64 =

[ Copy CODE to Clipboard ]

const truck_bmp as bytel[18241 = <
A. @, - 8, o = . B, A, BA. @A, A, A, 8. A, B, i
o, 8. o o 9, 6. 6. @ o 0. @ @ @8 0, @, @ | omeorascacod
@, 8, B, O, 8. @ @O, B, @B, @, @, @, 0, 0. @, @, |OmkBASICeod
A, B, A, @A, A, B, A, B, A, B, A. W, A. A, A. 4, ) mikroC code
A, @8, @A, @A, A, @, A, @, A, @, B, @, @A, @, B, A,
A, B, @A, B, @A, B, A, @, A, B, @, B, B, B, B, B, |
wer: 2,0.1 - 27012005 Swskem status: win MT like 05
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MANUAL
LCD Custom Character 23
mikroBasic for dsPIC30/33 and PIC24 includes the LCD Custom Character.
Output is mikroBasic for dsPIC30/33 and PIC24 compatible code. You can launch )
it from the drop-down menu Tools >» LCD Custom Character. g
Q
[ ]

— 1 LCD custom character

- . u E= E= [ = =)
hx? hx10 Save .. Load. _. Fill all Clear all Invert

Fant Presview:

fo B8 7+ cursor ling

 Bx 10 + curzor line

CGRAM address:

Char:

o]

Char data row:

GENERATE
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MANUAL
04 KEYBOARD SHORTCUTS
Below is a complete list of keyboard shortcuts available in mikroBasic for
dsPIC30/33 and PIC24 IDE. You can also view keyboard shortcuts in the Code
v .
o Explorer window, tab Keyboard.
8
o IDE Shortcuts
F1 Help
Ctrl+N New Unit
Ctrl+O Open
Ctrl+F9 Compile
Shift+F9 Compile All
Fl11 Program
Ctrl+F11 Compile and Program
F12 Preferences
Ctrl+Shift+E Edit Project
Shift+F4 View Breakpoints
Ctrl+Shift+F5 Clear Breakpoints

Basic Editor shortcuts

F3 Find Next
Alt+F3 Find in Files
Ctrl+A Select All
Ctrl+C Copy
Ctrl+F Find
Ctrl+H Replace
Ctrl+P Print
Ctrl+S Save Unit
Ctrl+Shift+S Save All
Ctrl+V Paste
Ctrl+X Cut

Ctrl+Y Delete Line
Ctrl+Z Undo
Ctrl+Shift+Z Redo
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Advanced Editor shortcuts

Ctrl+Space
Ctrl+Shift+Space
Ctrl+D Find
Ctrl+E

Ctrl+G

Ctrl+]

Ctrl+L

Ctrl+/
Ctrl+Shift+.
Ctrl+Shift+,
Ctrl+number
Ctrl+Shift-+number
Ctrl+Shift+1
Ctrl+Shift+U
TAB

Shift+TAB
Alt+Select
Ctrl+Alt+Select

Debugger Shortcuts

F4
F5
F6
F7
F8
F9
Ctrl+F2
Ctrl+F5
Ctrl+F8

25
Code Assistant o
Parameters Assistant g
Declaration o
Incremental Search ¢
Goto Line

Insert Code Template
Procedures List
Toggle Line Comment
Comment Code
Uncomment Code
Goto Bookmark

Set Bookmark
Indent Selection
Unindent Selection
Indent Selection
Unindent Selection
Select Columns
Select Columns

Run to Cursor
Toggle Breakpoint
Run/Pause Debugger
Step Into

Step Over

Start Debugger

Stop Debugger

Add to Watch

Step Out
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CHAPTER

- k
ATAYAYA

Building
Applications

Creating applications in mikroBasic is easy and intuitive. Project Wizard allows
you to set up your project in just few clicks: name your application, select chip,
set flags, and get going.

mikroBasic allows you to distribute your projects in as many units as you find
appropriate. You can then share your mikroCompiled Libraries (.mc1 files) with
other developers without disclosing the source code.

MIKROELEKTRONIKA: DEVELOPMENT TOOLS - BOOKS - COMPILERS



PROJECTS

e

New Project.

mikroBasic for dsPIC30/33 and PIC24 organizes applications into projects, con-
sisting of a single project file (extension .dbp) and one or more .dbas source files.
You can compile source files only if they are a part of the project.

The project file contains the following information:

- project name and optional description,

- target device,

- device flags (config word),

- device clock,

- list of the project source files with paths.

New Project

The easiest way to create a project is by means of the New Project Wizard, drop-
down menu Project » New Project or by clicking the New Project Icon . Just fill
the dialog with desired values (project name and description, location, device,
clock, config word) and mikroBasic for dsPIC30/33 and PIC24 will create an
appropriate project file.

There is also a slider for dsPIC30/33 and PIC24 data memory usage. You can
specify static and dynamic memory consumption. Static memory is assigned for
global variables and dynamic memory is assigned for local variables. Neither stat-
ic nor dynamic memory can occupy more than 80 % of total data memory space.
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New Project

Project Mame:

|M_l,lF'l0iect

Project Path: |C:\Proglam Filez'Mikroelektronik asmikroB azic dsPIC\Examp| [ Browse... ]
Drescription: by First Projecy |
Device: [P30F4013 =]
Memory zage
Dpmamic Link B0% Static Link B0
Device Flags:

Flags Scheme: |

VH Mew ” Save ”F!emove]

[] _cew_ou_Fs

[]_Lp = #FgF
[]_FRC = #F3
[]_Lrec = $F
[]_EXT = FB

[ _EcIo rLL4
[]_EcIo_rLla
[]_EcIo_pLii
[]_Frc_PLL4
[]_Frc_rLLs
[]_Frc_PLL1S
[ _x1_rLL4 =
W _xT_PLLE =
[] _xr_rLLle
[ _Hsz_PLL4

[]_csw FscH oW =

= #FFFF
CHM _OFF = §7FFF
#3FFF
F —
FF
AFF
FF
= $FFED
= $FFEE
& = $FFEF
$FFEL
+FFEA
= $FFEZ
#FFEL
#FFEG
$FFE7?
$FFFLl

_FOSC: 0xFFE&
_FWDT: Ox7FFF
_FEORPOR: OxFFFF
_FGE: OxFFFF
_FICD: OxFFFF

[ (B

Default Settings:
Default settings are as follows:
T PLL=8 oscillator - Enabled
‘wiatch Dog Timer - Dizabled
Clock switching - Disabled
Fail zafe monitor - Disabled
Background debug - Dizabled
Power-up/Brown out rezet - Enabled

[Cowes ][ een |

Editing Project

2

Edit Project.

To delete a project, simply delete the folder in which the project file
(extension .dbp) is stored.

L ok l LCancel

Afterwards, you can change project settings from the drop-down menu
Project » Edit Project or by clicking the Edit Project Icon . You can rename the
project, modify its description, change chip, clock, config word, etc.

page
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New File.

SOURCE FILES

Source files containing Basic code should have extension .dbas. List of source
files relevant to application is stored in project file with extension .dbp, along
with other project information. You can compile source files only if they are a part
of the project.

Search Paths

You can specify your own custom search paths: select Tools > Preferences from
the drop-down menu and then select Search Path.

When including source files with the uses clause, mikroBasic for dsPIC30/33 and
PIC24 will look for the file in the following locations according to this particular
order:

1. mikroBasic for dsPIC30/33 and PIC24 installation folder » “defs” folder
2. mikroBasic for dsPIC30/33 and PIC24 installation folder » “uses” folder
3. the project folder (folder which contains the project file . dbp)

4. your custom search paths

Managing Source Files

Creating new source file
To create a new source file, do the following:

1. Select File » New from the drop-down menu, or press Ctrl+N,
or click the New File Icon .

2. A new tab will be opened. It is a new source file. Select File » Save As
from the drop-down menu and name it as you wish.

If you use the New Project Wizard, an empty source file named after the project
with extension .dbas, is created automatically. mikroBasic for dsPIC30/33 and
PIC24 does not require you to have a source file named the same as the project,
it’s just a matter of convenience.
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2

Open File.

=

Print File.

=

Save File.

H

Save File As.

Close File.

Opening an Existing File
31
1. Select File > Open from the drop-down menu, or press Ctrl+O, or click the
Open File Icon . In Open Dialog browse to the location of the file that you want )
to open, select it and click the Open button. g
2. The selected file is displayed in its own tab. If the selected file is already open, o

its current Editor tab will become active. ®
Printing an Open File

1. Make sure that the window containing the file that you want to
print is the active window.

2. Select File » Print from the drop-down menu, or press Ctrl+P.

3. In the Print Preview Window, set a desired layout of the document and
click the OK button. The file will be printed on the selected printer.

Saving File

1. Make sure that the window containing the file that you want to
save is the active window.

2. Select File » Save from the drop-down menu, or press Ctrl+S, or
click the Save File Icon .

Saving File Under a Different Name

1. Make sure that the window containing the file that you want to save is the
active window.
2. Select File » Save As from the drop-down menu. The New File Name dialog
will be displayed.
. In this dialog, browse to the folder where you want to save the file.
. In the File Name field, modify a name of the file that you want to save.
5. Click the Save button.

FENS]

Closing a File

1. Make sure that the tab containing the file that you want to close is
the active tab.

2. Select File » Close from the drop-down menu, or right click the tab of the file
that you want to close.

3. If the file has been changed since it was last saved, you will be prompted to
save your changes.
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= BENIBIeRRL
o Icon
[ ]

A

View Assembly
Icon.

COMPILATION

Compilation

When you have created a project and written a source code, it's time to compile it.
Select Project » Build from the drop-down menu, or click the Build Project Icon
from the Compiler Toolbar.

Progress bar will appear to inform you about the status of compiling. If there are
some errors, you will be notified in the Error Window. If no errors are encoun-
tered, mikroBasic for dsPIC30/33 and PIC24 will generate output files.

Output Files

Upon successful compilation, mikroBasic for dsPIC30/33 and PIC24 will generate
output files in the project folder ( a folder which contains the project file .dbp).
Output files are summarized below:

Intel HEX file (.hex)
Intel style hex records. Use this file to program dsPIC30/33 and PIC24 MCU.

Binary mikro Compiled Library (.mc1)
mikro Compiled Library. Binary distribution of application that can be included in
other projects.

List File (.1st)
Overview of the dsPIC30/33 and PIC24 memory allotment: instruction addresses,
registers, routines and labels.

Assembler File (.asm)
Human-readable assembly with symbolic names, extracted from the List File.

Assembly View

After compiling the program in mikroBasic for dsPIC30/33 and PIC24, you can
click the View Assembly icon or select View » View Assembly from the drop-
down menu to review the generated assembly code (.asm file) in a new tab win-
dow. Assembly is human-readable with symbolic names. All physical addresses
and other information can be found in the Statistics Window or List File (. 1st).
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ERROR MESSAGES 23
Compiler Error Messages
2
Message Message Number o
)

Error: "%s" is not valid identifier 1
Error: Unknown type "%s" 2
Error: Identifier "%s" was not declared 3
Error: Expected "%s" but "%s" found 4
Error: Argument is out of range 5
Error: Syntax error in additive expression 6
Error: File "%s" not found 7
Error: Invalid command "%s" 8
Error: Not enough parameters 9
Error: Too many parameters 10
Error: Too many characters 11
Error: Actual and formal parameters must be identical 12
Error: Invalid ASM instruction: "%s" 13
Error: Identifier "%s" has been already declared 14
Error: Syntax error in multiplicative expression 15
Error: Definition file for "%s" is corrupted 16
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Message Message Number

v

o Error: ORG directive is currently supported for interrupts

© only 17

o

[ ]

Error: Not enough ROM 18
Error: Not enough RAM 19
Error: External procedure "%s" used in "%s" was not found 20
Error: Internal error: "%s" 21
Error: Unit cannot recursively use itself 22
Error: "%s" cannot be used out of loop 23
Error: Supplied and formal parameters do not match ("%s" 24
to "%s")
Error: Constant cannot be assigned to 25
Error: Constant array must be declared as global 26
Error: Incompatible types ("%s" to "%s") 27
Error: Too many characters ("%s") 28
Error: Soft Uart cannot be initialized with selected baud 29
rate/device clock
Error: Main label cannot be used in modules 30
Error: Break/Continue cannot be used out of loop 31
Error: Preprocessor Error: "%s" 32
Error: Expression is too complicated 33
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35
Message Message Number
v
Error: Duplicated label "%s" 34 g
o
[ ]
Error: Complex type cannot be declared here 35
Error: Record is empty 36
Error: Unknown type "%s" 37
Error: File not found "%s" 38
Error: Constant parameter cannot be passed by reference 39
Error: Pointer parameter cannot be passed by reference 40
Error: Improper use of operator "%s" 41
Error: Exit cannot be called from the main block 42
Error: Array parameter must be passed by reference 43
Error: Error occured while compiling "%s" 44
Error: Recursive types are not allowed 45
Error: Adding strings is not allowed, use "strcat" procedure 46
instead
Error: Cannot declare pointer to array, use pointer to struc-
) 47
ture which has array field
Error: Return value of the function "%s" is not defined 48
Error: Assignment to for loop variable is not allowed 49
Error: "%s" is allowed only in the main program 50
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Message Message Number

v
g’ Error: Start address of "%s" has already been defined 51

o

[ ]

Error: Simple constant cannot have a fixed address 52
Error: Invalid date/time format 53

Hint and Warning Messages

Message Message Number
Hint: Variable "%s" has been declared, but not used 1
Warning: Variable "%s" is not initialized 2
Warning: Return value of the function "%s" is not defined 3
Hint: Constant "%s" has been declared, but not used 4
Warning: Identifier "%s" overrides declaration in unit "%s" 5

Warning: Generated baud rate is "%s" bps (error = "%s"

percent) 6
Warning: Result size may exceed destination array size 7
Warning: Infinite loop 8
Warning: Implicit typecast performed from "%s" to "%s" 9
Hint: Unit "%s" has been recompiled 10
Hint: Variable "%s" has been eliminated by optimizer 11
Warning: Implicit typecast of integral value to pointer 12
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Message Message Number
Warning: Library "%s" was not found in search path 13
Warning: Interrupt context saving has been turned off 14

Linker Error Messages

defined

Message Message Number
Linker error: "%s" "%s" 1
Warning: Variable "%s" is not initialized 2
Warning: Return value of the function "%s" is not defined 3
Hint: Constant "%s" has been declared, but not used 4
Warning: Identifier "%s" overrides declaration in unit "%s" 5
Linker error: Constant "%s" was not found 6
Linker error: Address of the routine has already been 7

w
~

page

mikroElektronika mikroBasic for dsPIC30/33 and PIC24



MANUAL
mikrolCD (In-Circuit Debugger)

The mikroICD is a highly effective tool for Real-Time debugging on hardware
o level. The mikrolCD debugger enables you to execute the mikroBasic for

o dsPIC30/33 and PIC24 program on the host dsPIC30/33 or PIC24 microcontroller
g and view variable values, Special Function Registers (SFRs), RAM, CODE and
EEPROM along with the mikrolCD code execution on hardware.

Step No. 1

If you have appropriate hardware and software for using the mikroICD select
mikrolCD Debug Build Type before compiling the project.

Device: Ch%DS_E f:_e'ease Device:

P30F4013 v‘ bulld Type P30F4013 v]
- if you don't want -
arig to use mikralCD aris

080,000000 |MHz 080,000000 | MHz

Build Type Build Type

() pelease - ' () Release

() mikroICD Debug ’—b (%) mikroICD Debug
Debuoger Dehuoger

() Software Simulator Choose mikrolCD Debug () Software Simulatar

Build Type
) mikralCD Debuager if you want to use (=) mikralCD Debuoger
mikrolCD Debugger

Step No. 2

Choosing the mikrolCD Debug build type will select the mikrolCD Debugger
automatically. The Debugger Tool can also be selected from the Debugger »
Select Debugger drop-down menu.

Debugger | Run Tools  Help

Select Debugger » || Safbware

Compile the project and program dsPIC30/33 or PIC24 MCU.
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Step No. 3
39
= Run the mikroICD by selecting Run » Start Debugger from the drop-down menu
EE} or by clicking the Start Debugger Icon . Starting Debugger makes more options )
Start Debugger available: Step Into, Step Over, Run to Cursor, etc. Line that is to be executed is g
color highlighted (blue by default). There is also notification about the program o

execution, Watch Window Status Bar will be colored yellow during the program

execution.

mikrolCD Debugger Options

o Function
Name Description unctio
Key
Start
Debugger Start Debugger. [F9]
Run/Pause
Debugger Run or pause Debugger. [F6]
Stop Debugger | Stop Debugger. [Ctrl+F2]
Toggle breakpoint at the current cursor position. To
Toual view all breakpoints, select Run > View
Bizgkgoin s Breakpoints from the drop-down menu. Double [F5]
clicking an item in the Breakpoints Window List
locates the breakpoint.
Execute all instructions between the current
Run to cursor | . . .. [F4]
instruction and cursor position.
Execute the current Basic (single or multi—cycle)
Steo Tnto instruction, then halt. If the instruction is a routine [F7]
P call, enter the routine and halt at the first instruc-
tion following the call.
Step Over Execute. the current Basic (single or multi—cycle) [F8]
instruction, then halt.
Execute all remaining instructions in the current
Step Out . Ctrl+F8
°p o routine, return and then halt. [ 1

Note: when the mikroICD is halted MCU peripherals are not active.
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mikrolCD Debugger Example
40
Here is a step-by-step mikrolCD Debugger Example.
v
g Step No. 1
o . First you have to write a program. By using this example we will show how the

mikrolCD operates:

program LCD4bitTest
dim txt as string] 16]

i as byte
main:
ADPCFG = S1FFF
txt = "mikroElektronika"

Lcd Init EasyDsPICA4 ()
Led Cmd (LCD_CURSOR _OFF)
Led Cmd (LCD_FIRST ROW)
for i = 1 to 16
Led Chr(1l, i, txt[i-11)
next i
end.

Step No. 2
After successful compilation and MCU programming press F9 to start the
mikrolCD. After the mikrolCD initialization a blue active line should appear.

Z0 program LCD4bitTest

. [B] watch

= dim txt as string[lc] | ) d)u Of ST Wrike FAM | = Eq

L] i as bhyte

& @}Add Remove Properties @}.ﬂdd all [3. Remove Al
zs Select varible From st

+  ADPCFG = §1FFF et v

o Search For wariable by assembly name:

. txt = "mikroElektronika™ | bk E
30 Led Init EasyDsPIC4 () Mame Walue Address

. ADPCFG Cx00C0 00245

. Lod Cmd (LD CURSCOROFF) i 7 0x0C59

. Led Cmd(LCD FIRST ROW) Exk . 0x0C75
35 for i = 1 to 16

. Led Chefl, i, txe[i-1])

- next i

= end. PiC= 0000474 Tirne= 0,00 us
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Step No. 3

We will debug the program line by line. To execute code line by line press [F8]. It
is not recommended to the user to use Step Into [F7] and Step Over [F8] over
Delay routines and routines containing delays. In this case the user should use Run
to cursor [F4] function or Run [F6] function combined with Breakpoints.

z0 program LCD4bitTest

= dim txt as string[1lg]

. i as hyte
2; main:
ADPCFG = 31FFF
: txt = "mikroElektronika™
3; Lod Init_EasyDsPICE ()

+  Lod Cwd(LCD CURSOR OFF)
+  Led Crd{LCD FIRST ROW)

for i = 1 to 1o

- Led Chril, i, txc[i-1])
. next i

= end.

— b
(Bl Watch | )
| DO By 0% ©1 wWrite RAM | (g,

@].Add Remore Froperties @. Add Al @. Remove Al

Select variable From list:

e xe

Search For variable by assembly name:

|_t><t

Mame Value Address

ADPCFG 0:00C0 00245

i 7 O=0C59

Ext L} 00078
PC= 0000475 Time=0.00 us

All changes are read from MCU and loaded into the Watch Window. Note that
ADPCFG has changed its value to Ox1FFF.

Z0 program LCD4bitTest

= dim txt as string[1lg]

. i as bhyte
ZE main:
- ADPCFG = §1FFF

txt =

"mikroElektronika®

Led Init EasyDsSPICHE ()

+  Lod Crd(LCD CURSOR OFF)
»  Led Crd(LCD FIRST ROW)

for i = 1 to 16

- Led Chril, i, txt[i-1])
. next i

= end.

|E|Watch
| B0 Wy 0% 01 Write RAM | = B
[ Add

Select variable From list:

Remove Properties &. add Al @. Remove Al

|txt.

Search For wvariable by assembly name:

bt

Mame Value Address

ADPCFG Ox1FFF Ox02A5

i 7 0=0C59

Ext L.} 0%0C78
PiC= 0:x00047C Time= 0,00 us

mikroBasic for dsPIC30/33 and PIC24
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Step No. 4

42 Step Into [F7], Step Over [F8] and Step Out [Ctrl+F8] are mikrolCD debugger
functions that are used in stepping mode. There is also a Real-Time mode support-
o ed by the mikroICD. Functions that are used in the Real-Time mode are

o Run/Pause Debugger [F6] and Run to cursor [F4]. Pressing F4 executes the code
g until the program reaches the cursor position line.

= program LCD4hitTest:

|E| Watch
» yar txt : string[16]:; | @y 0% ST S0 Wrike RAM
. i : byte:
z5 [}. Add Remowe Properties [}. add All B. Remove Al
= hegin Select variable From lisk:
|txt Vl
ADPCFG := §1FFF; Search for variable by assembly name:
. en
. | Y
. Mame Yalue Address
. Led Init EasyDsPIC4(): ADPCFG Ox1FFF 0x0Z45
i 34 0x0C859
Led Cmd (LCD_CURZOR_OFF) %44 {0k Ox0C75

35 Led Cmd (LCD_FIRST ROW) ;

for i := 1 to 16 do
Led Chri(l,i,exe[i-1]);

40 end. PC= 000047 Time= 0,00 us
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Step No. 5

Run(Pause) Debugger [F6] and Toggle Breakpoints [F5] are mikrolCD debugger
functions that are used in the Real-Time mode. Pressing F5 marks the line selected
by the user for breakpoint. F6 executes code until the breakpoint is reached. After
reaching that breakpoint Debugger halts. Here in our example we will use break-
points for writing a word "mikroElektronika" char by char on LCD . Breakpoint is
set on Lcb_chr and the program will stop every time this function is reached. ¢

After reaching breakpoint we must press F6 again to continue the program execu-
tion.

F-Y
w

page

z0 program LCD4bitTest

|E| Watch =)
« dim txt as string[16] | GO By 02 1 Wrike RAM | l?*
. i as hyte
[}.Add Remaoye Properties [}.F\dd al [ remave &l
Z5 main: Select variable From list:
ADPCFG = §1FFF ezt v

Search For wariable by assembly name:

txt = "mikroElektronika® | i @
30 Lod Init_EasyDsPIC4() Marme Value &ddress
. ADPCFG 0x00C0 D0ZAS
3z | Led Cmd(LCD_CURSOR_OFF) i 7 0x0CE9

Led Cmd (LCD_FIRST_ROW) kxt e L]

35 for i = 1 to 16

. Led Chrfl, i, txc[i-17)
next i

= end. PC= 0x000475 Time= 0,00 us
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Breakpoints are divided into two groups: hardware and software breakpoints. The
hardware breakpoints are placed in the MCU and provide fastest debugging.
Number of hardware breakpoints is limited. There are 4 for the PIC24 and
dsPIC33 family while for the dsPIC30 family this number depends on the MCU
used. If all hardware breakpoints are used, then the next breakpoint will be soft-
ware breakpoint. These breakpoints are placed inside the mikrolCD and simulate
hardware breakpoints. Software breakpoints are much slower than hardware break-
points. These differences between hardware and software breakpoints are not visi-
ble in the mikrolCD software but their different timings are quite notable.That's
why it is important to know that there are two types of breakpoints.

. F P F R AR FF R RN

mikrolCD (In-Circuit Debugger) Overview

Watch Window

Debugger Watch Window is the main Debugger window which allows you to
monitor program execution. To show the Watch Window, select Debug Windows
» Watch Window from the View drop-down menu.

The Watch Window displays variables and registers of the MCU, along with their
addresses and values. Values are updated along with the mikrolCD code execution
on hardware. Recently changed items are coloured red.
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There are two ways of adding variable/register to the watch list:
45
(padd | - by its real name (variable's name in "Basic" code). Just select wanted
ADD Button variable/register from Select variable from list drop-down menu and click the )
Add Button . g
- by its name ID (assembly variable name). Simply type name ID of the o
variable/register you want to display into Search for variable by assemby name ¢

box and click the Add Button .

[ Remove  Variables can also be removed from the Watch Window. You just need to select the
Remove Button  variable that you want to remove and click the Remove Button .

4 add sl Add All Button adds all variables.
Add All Button

(& Remove &l Remove All Button removes all variables.

Remove All Button

|E| Watch
| 00 ® 0o oI witeram | ® [ B
[} Add Remove Properties [} Add Al @- Remave Al
Select variable from list:
ctris w |
Search for variable by assembly narme:
[t Y
Marme Yalue Address
il 3165 00000 fad)
W'l u] 00002
W2 u] 00004
W3 a 00006 .
W i 0x0008 T
S u] 00008
it u] Ox000C |
W7 u] 0:000E
WE u] 00010
Wa u] 0x0012
W0 u] 00014
1l u] 0x0016
Wlz u] 0x0015
W13 u] 000148
W14 2146 0001
Wis 2146 0x001E
_lib_lcdeustom_ mdb? & 0x0Ce2
_lib_lcdoustom_ mdbe 4 0x0C64
_lib_lcdoustom__ mdbs 2 0x0CE6 vl
PC= (000475 Time= 0,00 us =
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% e e Double clicking a variable or clicking the Properties Button opens the Edit value
window in which you can assign a new value to the selected variable/register.
Also, you can choose the format of variable/register representation between deci-
mal, hexadecimal, binary, float or character. All representations except float are
v . . . .

o unsigned by default. For signed representation click the check box next to the

g_ Signed label.

Properties Button

An item's value can also be changed by double clicking item's value field and typ-
ing the new value directly.

[B] Edit Value: ADPCFG

| 0000 O0FF |
Fepresentation
JDec (=) Hex I Bin ) Float ) Char

(] signed [I kK |] ’ Cancel ]

EEPROM Window

To show the mikrolCD EEPROM Window, select Debug Windows » EEPROM
from the View drop-down menu.

The EEPROM window shows current content of the MCU's internal EEPROM.
There are two action buttons concerning the EEPROM watch window :

- Flush EEPROM writes data from the EEPROM window
into MCU's internal EEPROM.

- Read EEPROM reads data from MCU's internal EEPROM and
loads it up into the EEPROM window.

mikroElektronika mikroBasic for dsPIC30/33 and PIC24



W | sE B FF B FF P FE PFFF FE  PE FF | FE | FF PP B FRFFIRRERFTIEREE

THCW | PP FF (PP | FF(FF (F(FF O FF | FF FF | FF | FF FF F | F W PI7EPREFRIRIVREY

0 J 60 00 69 (00 68 00 (T2 00 | 6F OO 45 00 | &C 00 &5 00 m. i k.r.0.Ele

TRRCI0 8 00 00 00 00 00O | DO | 0O 0o |00 | 00 0 o o k w
TECH) | FF R R R R FF R FF FF FF FF FF FF FF R FF DRRTREREEREIRITE m
TECED | P R R FF R FF R FE FF FF FF FF FF FF R FF DRRTRIEERRFIIIGE 5]
TECE) |FF P P B FF FE FF FF FF FF FE FF FF FE FF B PRRETRRERREIIIEE Q—
TECT) | P B B P FF B FF FF FF FF FE FF FE FE FF B PRRETRERRREEIIEE [ )

7rce0 | A As AR AR AC AA | AD AR (A A8 | AF M A | B | An | MRadabagaTaeag

FRRCI0 2 AL B} AR B4 | AA | BS AR B6 4R | BT AR BB AR B9 Aa  FMINTRpRgR-R As

JECM) | FF B P B B FF FF FF FF FF FF FF FE FE FF B RVRTRRERRREEREEE

JECBD | FE B B B FE FE FE PR PR FF FE FE FE FE FE B FVFTRVEERREYRVEY

WO |FF PP P FF PP PP FF FF PFF FF FF FF FF FF FF P FRTTRYRIRYRERYRY

OO | FE B B B FF BE FE FE FF FF FE FF FE FE FE B FVFTRVEERREVRVEY
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Code Window

To show the mikrolCD Code Window, select Debug Windows > Code from the
View drop-down menu. The Code window shows code (hex format) written into
the MCU. There is an action button concerning the Code window :

Read Code reads code from the MCU and loads it up into the Code Window.
Code reading is resources-consuming operation, so the user should wait until the
reading is over.

ReadCose

oo ] 0z I 04 I 06 I 03 I oA ] oc I i3 IASCH =]

O000FD | FRFFFF | FFFRFE | FFFFFE | FFFFFE | FFFFFF | FFFFFF | FFFFFF | FREFFF | VPPV VITPIS0IVY

000100 | 20E0E0 | 781FE0 200010 781F80 07010C B1004F 050000 FADDOD | 33 <US» <DLE> . € <US>

000110 | OFFFF7 | O7FFF6 | S7006A | 784090 | FEA0S1 200010 | DDO301 886316 | +70V] O@DO&<OLE>.

000120 | 57006C | 734090 FE&0S1 200010 | DDO281 886325 | 57006 784090 || 0@ O€<DLE>. O <5TX

000130 | FBSOBL | 200010 DO0201 86334 570070 784090 FEB081 200010 | O €<DLE>. <SOH> <5TR>+

000140 | DDOLBL | 886343 570074 784110 FE8L02 200011 DD0B0Z 886350 | O <50H>Cet. <DLE> A <2

000150 | 570076 | Fa410 FE&L0Z | 200011 DDOSOZ | 886360 | 570078 784110 | ¥. <DLE> A <5TH> O <DCL:

000160 | FES102 | 200011 DO0S02 866370 570063 780010 886380 570072 | €5Té> O «DCLx . <37 <k

000170 | 780010 | 886390 730005 700004 700003 EABDE0 S7BE4E 608810 | <DLE>. O <ENQ . <EOT:

000180 | 08380 | SOO162 B06311 | 20C640 | 7O0S090 | 20Ce60 | 708010 | 200685 | Scb<SOH»<DCl>c@AEL

000190 | 700015 | EASD00 600G12 | 806350 | 20CAC4 | ODON4 | 20CRE3 700013 | <MAK> .. € <DC2> <HT>Pe

000140 | EABOED | 806390 608810 806390 500162 806351 780004 708090 | €€0c<DLE> "Och <50H

000180 | 780003 | 708010 | EASOOD | 600912 | BO6331 780005 | 708090 806380 | <ETH> . <DLE>&.€ <DC2>

0001CO | 7OSS10 | O7009E | 0700A7 | O7O09C | 0700AS | O7009A | 0700A3 s0635L | <DLE>"2.§5. = ¥.%.£

000100 | 808330 | 700891 806340 EABDE0 806350 608610 070091 070094 | Oc'<BS>@cE€£Ec <DLE>

000IED | O7008F | 806330 | EASDA0 | 806380 | 6088LO0 806381 806310 700891 | O.0c€€€c<DlE>"DOec-

oootFo | 070087 | 070090 B063L0 | EASORO | B06330 608510 | 806381 806340 | ¥. 0. <DLE>c€€€C <DLE

000200 | 700831 | O7007E 806340 EABDEO 606380 606610 070079 070082 | <BSr~. @cEEEC <DIE>

000210 | 070077 | 806381 806340 700891 070073 07007C 806340 Easpen | w.Oc@c'<BS»s.|. @c

000220 | BOS380 | 608810 | 0700ED | 806341 200660 708090 | 20C640 708000 | €c<DLE>"m. Ac’ £OS

000230 | 200620 | 708090 806380 708810 070063 07006C 200010 ag63a0 | <GPC> A O€€c<DLE> "¢

000240 | FASOOD | 060000 FADOOZ 4700E0 200000 784660 470060 784090 | €., <5TR2 &, EHT L v
[ ]
STATUS: Idle

mikroElektronika mikroBasic for dsPIC30/33 and PIC24



RAM Window

To show the mikroICD RAM window, select Debug Windows » RAM from the
View drop-down menu.

The RAM Window displays the map of MCU’s RAM, with recently changed
items colored red.

The user can edit and change the values in the RAM window whose content will
be written to the MCU before the next instruction execution.

Eead R From: o0 Tor Oucra |
w l w l o l o t L I [ I o I [ I‘N'“ -2

(] 0000 oo o0 o1 oo oo o oxo o - B

e ] oo oo 0o o o oom

oran | oo | oo oo oo o oom oo oo P

7B [ ooon [ 000 o000 ooo0 oo oo R

07ED L] ] oo oo0o 0000 oo 0000 2000 ——

o 0000 0000 0000 0000 0000 ] o0 0000

0600 000 0001 o0ac 000 wrer 0000 0000 0000 .

0810 0000 0000 0000 0000 o6z 026 0000 0000

Lo weo o s T e o s o R

] L oo L] oo oo o0 o o e

san o0 [ oo oo oo o o oo et b

msa | oo o000 o000 oo oo o) o ram — T

80 oo oA o000 oo oo oon o000 o000 [0 £

0280 ] oo 0000 om0 oo o000 0000 o000

g0 0000 0000 0000 0000 0000 0000 0000 o000

0040 0000 0000 0000 0000 0000 0000 0000 0000
i i it ¥

Common Errors

- Programming the MCU while the mikroICD is active.

- Debugging Release build version of the program with the mikrolCD debugger.

- Debugging program code which has been changed, but has not been
compiled and programmed into the MCU.

- Selecting an empty line in the code for Run to cursor [F4] and Toggle
Breakpoints [F5] functions.

- Trying to Step Into [F7] the mikroBasic for dsPIC30/33 and PIC24 Library
routines. Use Step Over [F8] command for these routines

mikroElektronika mikroBasic for dsPIC30/33 and PIC24



CHAPTER

mikroBasic
Language Reference

Why BASIC in the first place? The answer is simple: it is legible, easy-to-learn,
structured programming language, with sufficient power and flexibility needed for
programming microcontrollers. Whether you had any previous programming expe-
rience, you will find that writing programs in mikroBasic is very easy. This chap-
ter will help you learn or recollect BASIC syntax, along with the specifics of pro-
gramming dsPIC30/33 and PIC24 microcontrollers.

MIKROELEKTRONIKA: DEVELOPMENT TOOLS - BOOKS - COMPILERS



mikroBasic SPECIFICS

Predefined Globals and Constants

In order to facilitate dsPIC30/33 and PIC24 programming, mikroBasic for
dsPIC30/33 and PIC24 implements a number of predefined globals and constants.

SFRs and related constants

All dsPIC30/33 and PIC24 SFRs are implicitly declared as global variables of
volatile word type. These identifiers have an external linkage, and are visible in
the entire project. When creating a project, the mikroBasic for dsPIC30/33 and
PIC24 will include an appropriate (*.dbas) file from defs folder, containing decla-
rations of available SFRs and constants (such as PORTB, ADPCFG, etc). All iden-
tifiers are in upper case, identical to nomenclature in the Microchip datasheets.

For a complete set of predefined globals and constants, look for “Defs” in the
mikroBasic for dsPIC30/33 and PIC24 installation folder, or probe the Code
Assistant for specific letters (Ctrl+Space in the Code Editor).

Math constants

In addition, several commonly used math constants are predefined in
mikroBasic for dsPIC30/33 and PIC24:

PI = 3.1415926
PI_ HALF = 1.5707963
TWO PI = 6.2831853
E = 2.7182818
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Accessing Individual Bits
51
mikroBasic for dsPIC30/33 and PIC24 allows you to access individual bits of 16-
bit variables. Simply use the direct member selector (.) with a variable, followed v
by a number 0. .15, with 15 being the most significant bit. g
Q
[ ]

For example:

' If RBO is set, set RCO:

if PORTB.0 = 1 then
PORTC.0 = 1

end if

There is no need of any special declarations. This kind of selective access is an
intrinsic feature of mikroBasic for dsPIC30/33 and PIC24 and can be used any-
where in the code.

Constants with value known in the compile-time can be used instead of numbers
0. .15, for example:

const pin5 = 5

' Set PORTB pinb
PORTB.pin5 = 1
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Interrupts

The dsPIC30/33 and PIC24 interrupt controller module reduces numerous periph-
eral interrupt request signals to a single interrupt request signal to the dsPIC30/33
and PIC24 CPU and has the following features:

- Up to 8 processor exceptions and software traps

- 7 user-selectable priority levels

- Interrupt Vector Table (IVT) with up to 62 vectors (dsPIC30) or
up to 118 vectors (dsPIC33 and PIC24)

- A unique vector for each interrupt or exception source

- Fixed priority within a specified user priority level

- Alternate Interrupt Vector Table (AIVT) for debug support

ISRs are organized in IVT. ISR is defined as a standard function but with the org
directive following it, connecting the function with specific interrupt vector. For
example org 0x1a is IVT address of Timerl interrupt source of the dsPIC
30F3014 MCU. For more information on IVT refer to the dsPIC30/33 and PIC24
Family Reference Manual.

Function Calls from Interrupt

Calling functions from the interrupt routine is possible. The compiler takes care

about the registers being used, both in "interrupt" and in "main" thread, and per-
forms "smart" context-switching between two of them, saving only the registers

that have been used in both threads. It is not recommended to use a function call
from interrupt. In case of doing that take care of stack depth.

Example

Here is a simple procedure which inverts state of PORTB upon each interrupt
from Timerl:

program TestTimerl

sub procedure TimerlInt org $1A
'#*% it is necessary to clear manually the interrupt flag:

IFSO = IFSO and S$FFF7 ' Clear TMRIIF
'**% user code starts here
LATB = not PORTB ' Invert PORTB
'**% user code ends here

end sub
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Code Optimization
53
Optimizer has been added to extend compiler usability, cut down the amount of
generated code and speed-up its execution. The main features are: v
o
©
Constant folding o
[ ]

All expressions that can be evaluated in the compile time (i.e. constant) are being
replaced by their results. (3 +5 -> 8);

Constant propagation

When a constant value is being assigned to a certain variable, the compiler recog-
nizes this and replaces the use of that variable by a constant in the following code,
as long as the value of a variable remains unchanged.

Copy propagation
The compiler recognizes that two variables have the same value and eliminates
one of them further in the code.

Value numbering
The compiler "recognizes" if two expressions yield the same result and can there-
fore eliminate the entire computation for one of them.

"Dead code" ellimination
The code snippets that are not being used elsewhere in the programme do not
affect the final result of the application. They are automatically removed.

Stack allocation
Temporary registers (Stacks) are being used more rationally, allowing VERY com-
plex expressions to be evaluated with a minimum stack consumption.

Local vars optimization
No local variables are being used if their result does not affect some of the global
or volatile variables.

Better code generation and local optimization
Code generation is more consistent and more attention is payed to implement spe-
cific solutions for the code "building bricks" that further reduce output code size.
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Creating User's Libraries

mikroBasic for dsPIC30/33 and PIC24 allows you to create your own libraries. In
order to create a library in mikroBasic for dsPIC30/33 and PIC24 follow the steps
bellow:

- Create a new Basic file, see Managing Source Files
- Save the file in the compiler's Uses folder:
DriveName:\Program Files\Mikroelektronika\mikroBasic dsPIC\Uses\
- Write a code for your library and save it
- Open the definition file for the MCU that you want to use.
This file is placed in the compiler's Defs folder:
DriveName:\Program Files\Mikroelektronika\mikroBasic dsPIC\Defs\
and it is named pMCU_NAMEdef.dbas, for example p30F4013def.dbas
- Add the Name_Of Your Library to the definition file for the MCU:
Repeat this step for each MCU that you want to use with your library
- Restart the compiler
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dsPIC30/33 and PIC24 Specifics
55
In order to get the most from the mikroBasic for dsPIC30/33 and PIC24 compiler,
the user should be familiar with certain aspects of dsPIC30/33 and PIC24 MCU. o
This knowledge is not essential, but it can provide a better understanding of the g
dsPIC30/33 and PIC24's capabilities and limitations, and their impact on the code Q.
[ ]

writing as well.
Types Efficiency

First of all, the user should know that dsPIC30/33 and PIC24's ALU, which per-
forms arithmetic operations, is optimized for working with 16-bit types. Although
mikroBasic for dsPIC30/33 and PIC24 is capable of handling types like byte, char
or short, dsPIC30/33 and PIC24 will generate a better code for 16-bit types word
and integer type so use byte, char and short only in places where you can signifi-
cantlly save RAM (e.g. for arrays dim a as byte[30]).

Nested Calls Limitations

There are no Nested Calls Limitations, except by RAM size. A Nested call repre-
sents a function call within the function body, either to itself (recursive calls) or to
another function.

Recursive calls, as a form of cross-calling, are supported by mikroBasic for
dsPIC30/33 and PIC24, but they should be used very carefully due to dsPIC30/33
and PIC24 stack and memory limitations. Also calling functions from interrupt is
allowed. Calling function from both interrupt and main thread is allowed. Be care-
full because this programming technique may cause unpredictable results if com-
mon resources are used in both main and interrupt.

Limits of Indirect Approach Through PSV

Constant aggregates are stored in Flash and are accessible trough PSV, which
means that there can be max 32KByte of constants.
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LEXICAL ELEMENTS

These topics provide a formal definition of the mikroBasic for dsPIC30/33 and
PIC24 lexical elements. They describe different categories of word-like units
(tokens) recognized by the language.

In tokenizing phase of compilation, the source code file is parsed (that is, broken
down) into tokens and whitespace. The tokens in mikroBasic are derived from a
series of operations performed on your programs by the compiler.

A mikroBasic program starts as a sequence of ASCII characters representing the
source code, created by keystrokes using a suitable text editor (such as the
mikroBasic Code Editor). The basic program unit in mikroBasic is a file. This usu-
ally corresponds to a named file located in RAM or on disk, having the extension
.dbas.

Whitespace

Whitespace is a collective name given to spaces (blanks), horizontal and vertical
tabs, and comments. Whitespace serves to indicate where tokens start and end, but
beyond this function, any surplus whitespace is discarded.

For example, the two sequences

dim tmp as byte
dim j as word

and

dim tmp as byte
dim j as word

are lexically equivalent and parse identically.
Newline Character

Newline character (CR/LF) is not a whitespace in BASIC, and serves as a state-
ment terminator/separator. In mikroBasic for dsPIC30/33 and PIC24, however,
you may use newline to break long statements into several lines. Parser will first
try to get the longest possible expression (across lines if necessary), and then
check for statement terminators.

mikroElektronika mikroBasic for dsPIC30/33 and PIC24



“SEn's = \ Y : : feddoecccccfope

Whitespace in Strings
57
The ASCII characters representing whitespace can occur within string literals,
where they are protected from the normal parsing process (they remain as a part of )
the string). For example, statement g
Q
[ ]

some string = "mikro foo"

parses to four tokens, including a single string literal token:

some string

"mikro foo"
newline character

Comments

Comments are pieces of text used to annotate a program, and are technically
another form of whitespace. Comments are for the programmer’s use only; they
are stripped from the source text before parsing.

Use the apostrophe to create a comment:

' Any text between an apostrophe and the end of the
' line constitutes a comment. May span one line only.

There are no multi-line comments in mikroBasic for dsPIC30/33 and PIC24.
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TOKENS

Token is the smallest element of a mikroBasic for dsPIC30/33 and PIC24 pro-
gram, meaningful to the compiler. The parser separates tokens from the input
stream by creating the longest token possible using the input characters in a
left—to—right scan.

mikroBasic for dsPIC30/33 and PIC24 recognizes the following kinds of tokens:
- keywords

- identifiers

- constants

- operators

- punctuators (also known as separators)

Token Extraction Example

Here is an example of token extraction. See the following code sequence:

end flag = 0

The compiler would parse it into four tokens:

end flag ' variable identifier
= ' assignment operator
0 ' literal

newline ' statement terminator

Note that end _f1ag would be parsed as a single identifier, rather than the keyword
end followed by the identifier fiag.
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LITERALS
59
Literals are tokens representing fixed numeric or character values.
v
The data type of a constant is deduced by the compiler using such clues as numer- g
ic value and format used in the source code. o
[ ]

Integer Literals

Integral values can be represented in decimal, hexadecimal or binary notation.

In decimal notation, numerals are represented as a sequence of digits (without
commas, spaces or dots), with optional prefix + or - operator to indicate the sign.

Values default to positive (6258 is equivalent to +6258).

The dollar-sign prefix ($) or the prefix Ox indicates a hexadecimal numeral (for
example, $8F or 0x8F).

The percent-sign prefix (%) indicates a binary numeral (for example, %0101).

Here are some examples:

11 " decimal literal

$11 " hex literal, equals decimal 17
0x11 ' hex literal, equals decimal 17
%11 " binary literal, equals decimal 3

The allowed range of values is imposed by the largest data type in mikroBasic for
dsPIC30/33 and PIC24 — 1ongword. The compiler will report an error if the literal
exceeds 4294967295 ($FFFFFFEF).
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Floating Point Literals
A floating-point value consists of:

- Decimal integer

- Decimal point

- Decimal fraction

- e or E and a signed integer exponent (optional)

You can omit either decimal integer or decimal fraction (but not both).

Negative floating constants are taken as positive constants with the unary operator
minus (-) prefixed.

mikroBasic limits floating-point constants to the range of
+1.17549435082 * 107-38 .. £6.80564774407 * 10°38.

Here are some examples:

0. "= 0.0
-1.23 1= -1.23

23.45e6 ' = 23.45 * 106
2e-5 "= 2.0 * 10*-5
3E+10 "= 3.0 * 10710
.09E34 ' = 0.09 * 10"34
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Character Literals
61
Character literal is one character from the extended ASCII character set, enclosed
with quotes (for example, "A"). Character literal can be assigned to variables of v
byte and char type (variable of byte will be assigned the ASCII value of the char- g
acter). Also, you can assign character literal to a string variable. o
[ ]

String Literals

String literal is a sequence of characters from the extended ASCII character set,
enclosed with quotes. Whitespace is preserved in string literals, i.e. parser does not
“go into” strings but treats them as single tokens.

Length of string literal is a number of characters it consists of. String is stored
internally as the given sequence of characters plus a final null character. This null
character is introduced to terminate the string, it does not count against the string’s

total length.

String literal with nothing in between the quotes (null string) is stored as a single
null character.

You can assign string literal to a string variable or to an array of char.

Here are several string literals:

"Hello world!" ' message, 12 chars long
"Temperature is stable" ' message, 21 chars long
"o ' two spaces, 2 chars long
"e" " letter, 1 char long

" " null string, 0 chars long

The quote itself cannot be a part of the string literal, i.e. there is no escape
sequence. You could use the built-in function Chr to print a quote: Chr(34). Also,
see String Splicing.
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62 KEYWORDS
Keywords are special-purpose words which cannot be used as normal identifier
names.

v

(=)}

g Beside standard BASIC keywords, all relevant SFR are defined as global variables

o and represent reserved words that cannot be redefined (for example: PORTE,
TMR1, T1CON, etc). Probe Code Assistant for specific letters (Ctrl+Space in Editor)
or refer to Predefined Globals and Constants.

Also, mikroBasic includes a number of predefined identifiers used in libraries. You
could replace them by your own definitions, if you plan to develop your own
libraries. For more information, see mikroBasic Libraries.
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Here is the alphabetical listing of keywords in mikroBasic for dsPIC30/33 and

PIC24:

abs

and
appactivate
array
as

asc

asm

atn
attribute
base
beep
boolean
byref
byte
call
case
cbool
cbyte
ccur
cdate
cdate
cdbl
char
chdir
chdrive
chr
cint
circle
class
clear
clng
close
command
compare
const
cos
createobject
csng
cstr
curdir
currency
cvar
cverr
date
dateadd

datedf
datepart
dateserial
datevalue
ddb
deftype
dim

dir

div

do
doevents
double
each
else
empty
end
environ
eof

eqv
erase
err
error
exit

exp
explicit
fileattr
filecopy
filedatetime
filelen
fix
float
for

form
format
freefile
fv

get
getattr
getobject
gosub
goto

hex

hour

if

iif

imp

include
input
instr
int
integer
ipmt
irr

is
isarray
isdate
isempty
iserror
ismissing
isnull
isnumeric
isobject
kill
lbound
lcase
left
len

let
line
loc
lock
lof

log
long
longint
loop
lset
ltrim
me

mid
minute
mirr
mkdir
mod
module
month
msgbox
name
new
next
not

not

nothing
now

nper

npv
object
oct

on

open
option
or

org

pmt

ppmt
print
private
procedure
property
pset
public
put

pv
gbcolor
raise
randomize
rate
real
redim
register
rem
reset
resume
return
rgb
right
rmdir
rnd

rset
rtrim
second
seek
select
sendkeys
set
setattr
sgn
shell

(<]
w

short
sin
single
sln
space ®
spc

sqr

static

step

stop

str

strcomp
strconv
string

sub

switch

syd

system

tab

tan

then

time

timer
timeserial
timevalue

to

trim

typedef
typename
ubound

ucase

unlock

until

val

variant
vartype
version
volatile
weekday

wend

while

width

with

word

write

XOr

page
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IDENTIFIERS

Identifiers are arbitrary names of any length given to functions, variables, symbol-
ic constants, user-defined data types and labels. All these program elements will be
referred to as objects throughout the help (don't be confused with the meaning of
object in object-oriented programming).

Identifiers can contain letters from a to z and A to Z, the underscore character “
and digits from O to 9. First character must be a letter or an underscore, i.e. identi-
fier cannot begin with a numeral.

Case Sensitivity

mikroBasic for dsPIC30/33 and PIC24 is not case sensitive, SO Sum, sum, and suM
are equivalent identifiers.

Uniqueness and Scope

Although identifier names are arbitrary (within the rules stated), errors result if the
same name is used for more than one identifier within the same scope. Simply,
duplicate names are illegal within the same scope. For more information, refer to
Scope and Visibility.

Identifier Examples

Here are some valid identifiers:

temperature V1
Pressure
no_hit
dat2string
SUM3

_vtext

... and here are some invalid identifiers:

Ttemp ' NO -- cannot begin with a numeral

Shigher ' NO -- cannot contain special characters

XOor ' NO -- cannot match reserved word

323.07.04 ' NO -- cannot contain special characters (dot)
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PUNCTUATORS
65
The mikroBasic punctuators (also known as separators) are:
v
[1 — Brackets (=)
©
() — Parentheses o
, —Comma ¢
: — Colon
. — Dot
Brackets

Brackets [ ] indicate single and multidimensional array subscripts:

dim alphabet as bytel 30]

r

alphabet[ 2] = "c"
For more information, refer to Arrays.
Parentheses

Parentheses () are used to group expressions, isolate conditional expressions and
indicate function calls and function declarations:

d=c¢c* (a + b) ' Override normal precedence
if (d = z) then ... " Useful with conditional statements
func () " Function call, no arguments

sub function func2(dim n as word)
' Function declaration w/ parameters

For more information, refer to Operators Precedence and Associativity,
Expressions, or Functions and Procedures.

Comma

Comma (, ) separates the arguments in function calls:

Lcd Out (1, 1, txt)

Furthermore, the comma separates identifiers in declarations:

dim i, j, k as word
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The comma also separates elements in initialization lists of constant arrays:
const MONTHS as byte[ 12] = (31,28,31,30,31,30,31,31,30,31,30,31)
Colon

Colon (:) is used to indicate a labeled statement:

start: nop

goto start

For more information, refer to Labels.

Dot

Dot (.) indicates access to a structure member. For example:
person.surname = "Smith"

For more information, refer to Structures.

Dot is a necessary part of floating point literals. Also, dot 